Invalid HTTP request to Wedos WAPI (request is empty)

When I try to send an HTTP request to Wedos WAPI, I get the response “request is empty”. Wedos WAPI.

When I send it to it looks fine. Pasteboard - Uploaded Image Wedos support told me that my json is probably not valid.

JSON url:
Body request text:

“{”“request”“: {”“user”“: ““tester””, ““auth””: ““202b62bc4646281f97d225db1249840c8452dd8f””, ““command””: ““domain-create””, ““clTRID””: ““a44B””, ““data””: {”“name”“: ““””, ““period””: 1, ““dns””: “””“, ““owner_c””: ““CONTACT””, ““admin_c””: ““CONTACT””}, ““test””: 1}}”

Do you know where the error might be?

Main.xaml (10.7 KB)


Please first try to make a call with postman …and once it is successful tey to replicate same in UiPath…that way you can identify the error and required parameters easily


Hi @pcman21

Could u please replace https and use http like below

Json Url:""

Hope it will work
If you want sample use this xaml (9.1 KB)


None of the above works.

Postman also reports the same error and the request must always be sent as https, otherwise it doesn’t respond at all.

Wedos support wrote me to send them the “whole script” that I send to that WAPI. They still suspect bad parsing of the request.

Is there any way to get the request coming from UiPath or Postman?


If postman and UiPath both are giving error then ideally the request itself is going in wrong so the request need sto be verified from your side to ensure that matches the required body or header items

If paraing is going wrong try usinng online json parsers to check the structure once


Problem solved:

I had to add “request=” before and then put the JSON. I also had to add header Content-Type: application/x-www-form-urlencoded header

“request={”“request”“: {”“user”“: ““””, ““auth””: ““202b62bc4646281f97d225db1249840c8452dd8f””, ““command””: ““domain-create””, ““clTRID””: ““a44B””, ““data””: {”“name”“: ““””, ““period””: 1, ““dns””: “””“, ““owner_c””: ““CONTACT””, ““admin_c””: ““CONTACT””}, ““test””: 1}}”

Thank you for your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.