Intermittently encountering SelectorNotFoundException

I was able to automate a desktop application using UIPath. It works fine running a couple of days but then one day all of a sudden, it began encountering SELECTORNOTFOUNDEXCEPTION. Not really sure what happened but here’s what I haven’t done and have tried already.

  • I didn’t manually update studio or anything
  • Tried re-attaching element several times (simple button click)
  • Tried restarting the machine
  • Verified target selector is accurate/accessible through UIexplorer
  • Running Uipath with elevated permission

What’s more confusing is one time I was able to execute the bot without error without knowing how it suddenly worked again… and then when the machine got rebooted it stopped working again!

This has been really frustrating. :confounded: Didn’t know UIpath has this kind of reliability issues. Please help!

everyone’s Qn since day one. :joy:

Has anyone already found the cause/resolution?

Hi @zell12,

One small suggestion try to use * in the selectors with contain changes dynamically.
like in aaname or title or Text etc.,


Hi @zell12,

Selector not found exception comes when we do not have stable selector for the objects. It can be due to dynamic nature of the selectors. You can refer to below link for understanding of the selectors.

You can create a stable selector yourself and by using UiPath explorer and playing with the attributes and properties of it.


Ive actually played with the selectors quite a bit but no luck. Tried reindicating element and doing an attach to live element as well.
What confuses me is it will just work suddenly after I leave it for a bit, without me knowing what just happened.

Thanks for your inputs though…

Does anyone know if UIpath has incompatibility issues with Windows 7?
The OS I’m running on where I’ve seen intermittent issues is Windows 7, but when I’ve tried to run the bot on a windows 10, the issue doesn’t seem to replicate. It works completely fine on Windows 10.
Has anyone seen this kind of issue?