Interaction with the Web application is not working if the VM close

Hi All

I built the Uipath bot interacting with the Web application in the Uipath 2019.10.4 studio version. The bot faced the issue interacting with the Web application if the VM disconnected/ closed. If the VM is open (login to the VM), the Uipath bot interacts with each element in the Web application.

FYI. I did not receive any error when installing the Chrome extension in the robot machine.

This issue starts after I install the Uipath studio version to 2020.10.10 and the Orchestrator version to 2020.10.1 from 2019. Until I open the VM, the bot is not interacting with the Web application.
I have also added the Environment variable of the ‘UIPATH_SESSION_TIMEOUT’ with the value of 60, but the issue still exists.

Did any of you come across this issue and resolve it? Please share your comments.


1 Like


Try to upgrade the packages from Manage packages


Hey @G3Devi

Please try with the below troubleshooting steps,

  1. Kindly install the robot in Service mode

  2. Please don’t disconnect the VM instead sign out the machine and then trigger the job

  3. Make sure there is no startup applications coming across bot automation run

  4. May be you can also try remote debugging to see what’s wrong in a bit easier way

  5. Also, analyse your exception screenshots of bot have taken some already


Hi @G3Devi

Have a look on the thread


Hi All

Issue resolved.

  1. Install Uipath Robot service.
  2. Create a simple bot with TakeScreenshot and Save Image activities.
    2a. Capture the Image Width, Height, and Bit Depth of the saved image file (image file properties).
  3. Log in to the Orchestrator and change the Resolution in the Robot settings.
    3a. Login to Console as No.
    3b. Enter Resolution Width, Resolution Height, and Resolution Depth (2a step).
  4. Open the RUN command
    4a. Open the SystemPropertiesAdvanced on the Run command
    4b. Click on the Environment variables button under the Advanced tab.
    4c. Add/ update the ‘UIPATH_SESSION_TIMEOUT’ with the value of 60.
  5. Restart the Robot service
  6. Sign out from the Robot machine.

Thanks to the Uipath Technical Team for resolving this issue.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.