Intelligent OCR - Machine Learning Extractor - Internal Server Error 500

Hey guys…

I had this workflow running for sometime now. But it looks like after the Orchestrator update, this is not working…

I have a workflow that is used with Intelligent OCR to read some invoices. Somehow, today, I’m getting this error from machine learning extractor.


Anyone have any idea on why I’m getting this internal server error?
@loginerror @Ioana_Gligan

Hi @Lahiru.Fernando

Is it still the case?

1 Like

Yeah… I have being trying since today morning

We’ll look into that!

1 Like

Hey @loginerror

I checked it couple of minutes ago as well… I still get the error. This time I checked from a different machine. It was perfectly working on this one too…

It’s the same error I shared in the main topic…

1 Like

Checking right now!

1 Like

Hi @Lahiru.Fernando I cannot reproduce error, service seems to be working.

Are you by any chance sending a document which is fairly large, like 2-3MB, and rotated sideways? Can you share the document which produces this result?


Hey @alexcabuz

Thanks for the reply.

I tried the same thing again now, but I still get the error…

These are not too large files. I actually tried the same docs given in examples here in the forum. They were working perfectly before. Not sure what happened…

This is the solution (228.8 KB)

This also includes the docs that I tried…

Hi @Lahiru.Fernando I couldn’t get the issue repo’d neither by pointing directly to the invoices model endpoint and do the inference using the 01.pdf from your zip. Can you share the endpoint that your request was sent to that ended up getting the “Invalid server response” error?

Hello @taoma

Thanks for your reply. This is the endpoint that I have set. Did this change after the latest Orchestrator update?

Hi @Lahiru.Fernando, it’s the same endpoint that we have been using. Few more questions - are you still getting the same error now? was the error happened before updating Orchestrator? what else got changed on your side in the past few days? on the error case, can you capture the request/response payload using wireshark or fiddler and send us to take a look? Thanks!

1 Like

Also @Lahiru.Fernando do you mind to share me in private message the license key that you were using?

1 Like

Will share the details shortly @taoma Thank you so much for your kind support. Give me couple of minutes and I will get back to you…

Hello @taoma

Sorry for my late reply. I’m still getting the error. I have the same solution in two machines. Not in a shared folder. Before the recent update of the Orchestrator, this program was working perfectly in both machines. Without any change. Since the last Orchestrator update, both are not working because of this same error. I even tried the sample solutions given here in the forum when introducing Intelligent OCR, those are also failing because of the same error.

I will send you a PM on the API key

1 Like

Hi @Lahiru.Fernando got your api key in pm. Confirmed that it’s the key that causing the issue. We have engaged right colleague to look into the issue and hopefully can provide a fix soon. Please stay tuned.

In the meanwhile, you may want to try generating a new key to use by register/login to your own account. Please give it a try and let me know how that goes.


Hi @Lahiru.Fernando

I believe this issue is now solved? :slight_smile:

1 Like

Hey guys…

Thank you so much… This issue is not fixed. it’s working like charm… Special thanks to @taoma for being touch with me through all the stages and giving updates and proposing different solutions to get it fixed. I do really appreciate your effort… Thank you SO much…

So the problem was with the API keys. and now it is fixed. For the end point property of the Machine Learning Extractor, we still need to use “

Why I mentioned the end point is some proposed a different URL.

Awesome work guys…


@Lahiru.Fernandoit thanks! it was great pleasure that we can help out.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.