Installation Fails on 2020.4.1 Orchestrator

Hi, I’m kind of stuck installing UiPath Orchestrator ver 2020.4.1. It keeps on failing, and I cannot find the cause.

Is there anyone facing the same problem?

I was checking for the new installing procedure whether it works out or not. First I tried to upgrade a 2019.10 version of OC to 2020.4.1, and it didn’t work out. “An error occurred. Please retry” kind of message appeared, and nothing in detail. As I wanted to see the new environment fast, I just decided to create a new environment and have it plain installed.

And again, an error occurred and I am troubled. I tried the MSI installer first and it failed with poor information. Then I tried the platform installer and it failed too, but this time it gave a log. I’ll show it later.

My testing environment:

  1. Windows Server 2019 Standard Edition
  2. The procedure I used is in Orchestrator導入ステップバイステップガイド [2021.4 対応版]
  3. I installed the following product
  • .NET Framework 4.8
  • .NET Core 3.1 Hosting Bundle:
  • URL Rewrite 2.1
  • Server Roles and Features
  1. I ran the PS Script “Install-WindowsFeature -Name Web-AppInit”
  2. I used the MS SQL Server Express 2019 Edition and SSMS(18.5.1)
  3. I used Self-Signed Security (SSL) Certificate
  4. The MSI installer SHA1 hash is “ef0b9a7a71e9db9ceb8eb1802fa9216126c89ad6”
    The Platform installer SHA1 hash is “859846b4bb41bbeaa23d953e320ce9463cbd2004”

I’ll paste the log from where a bit before the error starts. I’m sorry the log is partially Japanese. It says:
Configuring IIS
Writing System Registry
Setting up the WIndows Firewall
Copying new files
Creating the folder
Updating the registered components
…and the error starts.

[0C64:1374][2020-06-14T18:27:42]i000: ExecuteMsiMessage: Log = IIS を構成中です
[0C64:1374][2020-06-14T18:27:42]i000: ExecuteMsiMessage: Log = IIS を構成中です
[0C64:1374][2020-06-14T18:27:47]i000: ExecuteMsiMessage: Log = システム レジストリの値を書き込んでいます
[0C64:1374][2020-06-14T18:27:47]i000: ExecuteMsiMessage: Log = Orchestrator_CopyConfigurationFilesBack
[0C64:1374][2020-06-14T18:27:47]i000: ExecuteMsiMessage: Log = Orchestrator_UpdateConfigurationAndDatabase
[0C64:1374][2020-06-14T18:27:47]i000: ExecuteMsiMessage: Log = Orchestrator_ApplyDbMigrations_Rollback
[0C64:1374][2020-06-14T18:27:53]i000: ExecuteMsiMessage: Log = ExecXmlFile
[0C64:1374][2020-06-14T18:27:53]i000: ExecuteMsiMessage: Log = Windows ファイアウォールの構成をインストール中です
[0C64:1374][2020-06-14T18:27:53]i000: ExecuteMsiMessage: Log = Windows ファイアウォール構成をロールバック中です
[0C64:1374][2020-06-14T18:27:53]i000: ExecuteMsiMessage: Log = 新しいファイルをコピーしています
[0C64:1374][2020-06-14T18:27:58]i000: ExecuteMsiMessage: Log = フォルダーを作成しています
[0C64:1374][2020-06-14T18:27:58]i000: ExecuteMsiMessage: Log = コンポーネントの登録を更新しています
[0C64:1374][2020-06-14T18:28:01]i000: ExecuteMsiMessage: Log = メッセージの種類: 2、引数: 1
[0C64:1374][2020-06-14T18:28:01]i000: ExecuteMsiMessage: Log = メッセージの種類: 2、引数: 1
[0C64:1374][2020-06-14T18:28:01]i000: ExecuteMsiMessage: Log = 1: 2 2: 0
[0C64:1374][2020-06-14T18:28:01]i000: ExecuteMsiMessage: Log = 1: 2 2: 1
[143C:04A8][2020-06-14T18:28:01]e000: Error 0x80070643: Failed to install MSI package.
[143C:04A8][2020-06-14T18:28:01]e000: Error 0x80070643: Failed to execute MSI package.
[0C64:1374][2020-06-14T18:28:01]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[0C64:1374][2020-06-14T18:28:01]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[0C64:1374][2020-06-14T18:28:01]i319: Applied execute package: UiPathOrchestrator.msi, result: 0x80070643, restart: None
[0C64:1374][2020-06-14T18:28:01]e000: Error 0x80070643: Failed to execute MSI package.
[0C64:1374][2020-06-14T18:28:01]i000: ExecutePackageBegin: UiPathOrchestrator.msi - should execute: False
[143C:04A8][2020-06-14T18:28:01]i318: Skipped rollback of package: UiPathOrchestrator.msi, action: Uninstall, already: Absent
[0C64:1374][2020-06-14T18:28:01]i000: Progress: Install progress: 62
[0C64:1374][2020-06-14T18:28:01]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[0C64:1374][2020-06-14T18:28:01]i319: Applied rollback package: UiPathOrchestrator.msi, result: 0x0, restart: None
[143C:04A8][2020-06-14T18:28:01]i329: Removed package dependency provider: {DA61E6D4-0D5B-4D60-B4FC-031EE5A480E7}, package: UiPathOrchestrator.msi
[143C:04A8][2020-06-14T18:28:01]i351: Removing cached package: UiPathOrchestrator.msi, from path: C:\ProgramData\Package Cache{DA61E6D4-0D5B-4D60-B4FC-031EE5A480E7}v20.4.1.0
[0C64:1374][2020-06-14T18:28:01]i000: ExecuteComplete: Status: -2147023293
[143C:04A8][2020-06-14T18:28:01]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{b6d4ea30-24d3-4485-8288-6cf9b886aacb}, resume: None, restart: None, disable resume: No
[143C:04A8][2020-06-14T18:28:01]i330: Removed bundle dependency provider: {b6d4ea30-24d3-4485-8288-6cf9b886aacb}
[143C:04A8][2020-06-14T18:28:01]i352: Removing cached bundle: {b6d4ea30-24d3-4485-8288-6cf9b886aacb}, from path: C:\ProgramData\Package Cache{b6d4ea30-24d3-4485-8288-6cf9b886aacb}
[143C:04A8][2020-06-14T18:28:01]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{b6d4ea30-24d3-4485-8288-6cf9b886aacb}, resume: None, restart initiated: No, disable resume: No
[0C64:1374][2020-06-14T18:28:01]i000: ApplyComplete - Status: -2147023293; Result: None



hi @AigoHigurashi
Check your Antivirus that blocking it or
Check your firewall/windows rules has been place as restriction to run the app (get help with your windows and network admin to check the the relevant rules has been applied or not)

I’m installing Orchestrator at a customers site and receiving the exact same error. We have been troubleshooting but no luck.

The errors in the log is as below. Please advice.

Error 0x80070643: Failed to install MSI package.
Error 0x80070643: Failed to execute MSI package.
Error 0x80070643: Failed to configure per-machine MSI package.


Unfortunatelly, I couldn’t resolve the issue.

If you are facing this issue as a part of your business against your customer, I would advice you to ask UiPath tech support on your region.

I only used this forum as I was doing for my personal experience.

Good luck!

Aigo Higurashi

1 Like

Thanks for your reply, I have been in contact with Technical Support but have not been able to solve the problem so this was too address this problem here also to show that you are not alone receiving this error. I have tried disabling Firewall and Antivirus, tried to reinstall all Prerequisites but still receiving the same error.

Will contact Technical support again and update here if i’m able to solve the problem!

1 Like

Hi @danielstrid
I am facing the same issue, are you able to solve?

Unfortunately, I’m having the same issue. Did anyone manage to do something regarding this problem?

In my case I could troubleshoot by installing through command line using Verbose Logging by starting the installation with this command: UiPathOrchestrator.msi /l*vx log.txt

It showed an error with the certificate that the installer did not inform about, I used a self generated certificate for installation of Orchestrator, after instruction from UiPath support, then replaced with the Certificate handed to me by the customer with a different hostname. It required a Registry key change and a change to the database for Identity Server that the UiPath support gave information about.

After that I also faced a problem with the IIS Application Pool not starting and that was due to the Microsoft Monitoring Agent, but was able to solve that after some troubleshooting. See below thread regarding that problem.