Install & Enable UiPath Extension on Browser Silently via GPO

Hi Automation Gurus,

Am using UiPath v2020.10.4 and am trying to Silently Install and Enable UiPath Extension (Install from Group Policy)

I have followed the following guides:

However, although it works in installing UiPath extension on the browser, the pop up to enable the extension still shows up and user have to click on enable extension for the extension to be enabled.

Any idea why this is happening?


Hello @robot_learner ,

plz go through the below doc.

Check whether you did the same method for the silent installation.

Hello @Rahul_Unnikrishnan

Yup, we had followed the necessary command line parameter for installation too, for our version v2020.10

UiPathStudio.msi ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages,EdgeExtension,ChromeExtension CHROME_INSTALL_TYPE=STORE /Q

Installation of UiPath extension on our user’s Edge and Chrome is done silently. However, it does not seems to be the case for the enablement of the extension (i.e. user sees pop up to enable the extension), which we do not want.

Thanks! :slight_smile:

Hello @robot_learner ,

So during the execution is it asking this authentcation popup?

Hello @Rahul_Unnikrishnan

After software is installed on machine, user have to manually launch chrome/edge browser > Click ‘Enable Extension’. This is a once-off action, after-which, they are good to go.

However, as per the docs, user should not even see the prompt for enablement of the extension and we want to avoid this.

Hello @robot_learner ,

Plz try to install any other extension direclty in chrome and check whether you are getting that authentication popup. I think its part of the security to give the permission to all the extensions installed. Maybe you can refer the below doc.