Insights Setup Fails At: Ingesting Initial LicenseLog Failed

Insights Setup fails at: Ingesting initial LicenseLog failed

Actual Errors may be:

  • Error Ingesting initial LicenseLog failed
  • Debug System.Data.SqlClient.SqlException (0x80131904): The parameterized query '(@Unattended bigint,@NonProduction bigint,@Headless bigint,@Test' expects the parameter '@GracePeriodDate', which was not supplied.

Resolution:

  1. Go to https://<insights URL>/app/account/login and login to Insights
  2. Go to https://<insights URL>/app/test and ensure all the processes are running
  3. If the all but the proxy service are running, go to the next step
    • If other services are not running, go to http://localhost:3030 on the insights machine and restart the services
  4. If the proxy service is the only service not running, do the following:
    • Go to http://localhost:14996/paths - a json file should be downloaded or displayed. If a 404 is seen, then the IIS logs need to be checked.
    • If the json file displays, recheck app/test and if the Proxy service is still down, open a ticket with UiPath Support
    • If there is an exception displayed, see".Net Trust Levels"
    • For IIS logs, go to C:\inetpub\logs\LogFiles\W3SVC2 - Note: log location may be different. This can be checked by checking the logging configuration for SisenseWeb in the IIS site.
    • Open the log and see if there is a sub status for the error message.
  5. Take action based on the sub status error message
    • Most likely this is an IIS configuration issue.
    • 404.7 - See "Disable Request Filtering"
    • Regardless of the error, if the paths location is not displaying a path, indicates an IIS setting is breaking the component.

Disable Request Filtering

  1. Open IIS
  2. Go to the site 'SisenseWeb'
  3. Go to 'Request Filtering' under IIS settings.
  4. After request filtering is opened, go to 'Edit Feature Settings...' on the left of the screen in the 'Actions' panel
  5. Settings should look like this. Make sure to save the changes:

.NET Trust Levels

  1. Open IIS
  2. Go to the site 'SisenseWeb'
  3. Go to '.NET Trust Levels' under ASP.NET settings.
  4. Make sure the trust level is set to Full.