Insights: OOTB Dashboards Not Visible

How to handle when Insights tab in Orchestrator the OOTB is not visible ?

Troubleshooting Steps:

  1. When setting up the tenant via the Insights admin tool, the user is given the option of setting the default access for the OOTB dashboards to All, Viewers, Editors or Insights Admin
    • All - Anyone with the Insights View or Create permission can see the dashboard. Most users want to use this permission.
    • Viewers - Anyone with the Insights View permission can see the dashboard.
    • Editors - Anyone with the Insights Edit permission can see the dashboard.
    • Insights Admin - Only the Insights admin can see the dashboard (configured at runtime).
  2. Try checking to see if the dashboard is present in Insights via the Insights Admin account
    • Log out of Orchestrator or open an incognito browser.
    • Go to https://<insights url>/app/account/login
    • Login with the Insights admin account.
    • In the Analytics tab, select the folder for the given tenant (naming convention is <tenant name>-OOTB). The folders will be on the left hand side of the screen. Just click the folder to see what dashboards it contains.
    • If the dashboard are present, its a permission issue. If the dashboards are not present, the setup failed.
  3. If it is a permission issue, the Insights setup tool can be rerun or the group that corresponds to the desired role, can be added to each dashboard. This must be done via the Insights Admin account.
    • First, review this section in the Dashboard Ownership and Sharing guide (Make sure to look at the right version of Insights)
    • Go to one of the OOTB dashboards
    • Click the share icon (side ways V icon).
    • Add the corresponding groups.
      • Edit - <tenant name>-Editor
      • View - <tenant name>-Consumer
      • All - Everyone. NOTE: Adding this group means that anyone in any tenant with Insights would be able to view the dashboard.
  4. If it is not a permission issue, the Insights Admin tool needs to be rerun and then the logs need to be checked.
    • Rerun the insights admin tool at C:\Program Files (x86)\UiPath\Orchestrator\Tools\UiPath.InsightsAdminTool.exe for enabling the tenant.
      • Ensure to run it as an Administrator!
      • When re-enabling the tenant, the cube probably needs to be rebuild as well (This is because the setup tool probably had multiple errors).
    • After running it, it will probably say: 'Could not setup tenant <tenant name>'. If it says, this indicates the setup failed. If it says 'Complete' it means the setup was successful.
    • If the setup was unsuccessful, check the log in the directory C:\Program Files (x86)\UiPath\Orchestrator\Tools\
    • If the log is not present, it means the tool was not run as an administrator.
    • In the log search for 'Error'. Try search for the error message or share the log with UiPath Support.