Input values to a field which change its index or location every time the page loads

uiautomation

#1

Hello All, how to enter value to a field which change its position in the web page every time the page loads. I used UI Explorer to and see the index changes every time. Tried find element , anchor etc but nothing seems to work. Can anyone please suggest the right way, thanks.


#2

Does it have an aaname attribute in the selector? If possible please share the screenshot of UiExplorer with the selector of particular field in it.


#3

it would not be possible to share the screen print, however I don’t see any aaname attribute in the selector. The list of attribute I see is class, id,isleaf, name,parentclass,id,tablecol,row.tag,type
the selector is generating index number which changes every time. wildcard in index number will anyways not work , as it will not know under which field the value is to be entered.

Any way we can find the filed name and enter value in it.


#4

Does it have a field name? It would be great if you could share a portion of the website which includes the field.


#5

sorry Midhun I cannot upload and attach screen-prints to the forum.
yes their is a field name.

To make it simple for you to understand, their is a field, name XYZ and the data it accepts is numeric.
The field is in a table structure in UI, we have an option customize the screen. with every customization the field changes it location in the table structure.

Set text activity does not give any error but then it populates the input in ABC filed instead of XYZ, reason with new customization, ABC is now in the location where XYZ was.

hope this will help.

This should be a very generic problem because it is not an uncommon thing in UI.

Just need guidance on how to identify XYZ field , which can be anywhere in the we page and enter value in it.
Thanks in advance.


#6

Can you try and select the parent field? So don’t select just the input field, but ideally select the parent field which contains both the input field and the field name. Use a click activity on that to activate the input field.

For example, this site has the same problem: http://rpachallenge.com/
But if you select it like in the image below, it works.

image


#7

@manojsahariya

Use Anchor base activity, there use find element activity and mention select Company as an anchor. Then Use Type into activity in right side.

Regards,
Mahesh


#8

and what activity to use ?, it is not working with set text and type into, not even recognizing the element.

also both of the above activities set Clipping Region, x and y coordinates, will it not freeze the position of the field in the web page ?


#9

Thanks Mahesh, it worked.