Initallsettings get asset value could not find an asset with this name 1002

Hi,

I am trying to test InitAllSettings.xaml and I am getting an error. Specifically, In UiPath 19.10.1 (stable), in REFramework, in InitAllSettings.xaml, I am getting: Get Asset Value: Could not find an asset with this name. Error code: 1002

Maybe I’m confused about the “Try Loading Server Assets” phase in InitAllSettings.xaml. It seems to me that this workflow first reads values from Data/Config.xlsx and then fetches from Orchestrator (overwriting any values with names matching any from the Config spreadsheet).

I don’t seem to have a problem reading from my Config.xlsx because it’s printing the right values. The problem is the second phase, when you try to get assets from Orchestrator. Right now, I’m not planning on getting any assets from Orchestrator. However, in Try Get Asset, I see the Get Asset Value has a property called “AssetName” which is set by default to “row(“Asset”).ToString”:

First of all, shouldn’t that be row(“Name”).ToString?

Second, it seems to be searching Orchestrator for an asset with that name and when it doesn’t find it, an error or exception occurs. It shouldn’t be able to find it in Orchestrator, since I am not planning on using Orchestrator so far. Shouldn’t the Get Asset activity simply catch the exception and continue on without an issue?

Hi @jplusplus

Is the particular asset added in orchestrator

Thanks
ashwin S

No, I’m not trying to load any assets from Orchestrator. Should I comment out / delete the “Try Loading Server Assets” sequence?

I run into the same problem! I ran the same asset on orchestrator and it works fine, but when I try to use the asset from Config it throws the same error.
Have you found a solution yet?