"Indicate Element" doesn't work with Default UiEngine for Desktop Applications

Unable to detect several intra menu selector in a specific machine, using Default selector. Changing “UI Frameworks” can make it work, but it doesn’t in Studio or Default.

This happens in Ribbons, Menus and other specific Windows elements.

The detection and selectors works fine in 2 other machines with similar configurations.

Windows Server 2016 Standard 64 bit
UiPath Studio 2019.10.5 Enterprise
UiAutomation 2019.11.5 (Started testing with 2018.3.6897)
.NET Framework v4.0.30319

How to reproduce

From Studio, open UiExplorer, choose Indicate Element, tries to select “Move to” button (for example)

Current behaviour

Expected behaviour

The example above is using File Explorer, but it happens in all Windows Applications, including a .NET developed one that I need to automate.

The problem is intermittent, started to happen 2 days with no apparent reason since there’s no relevant Windows Update applied recently:

Possible solutions

  1. Can rewrite all that part using UiAutomation framework, but doesn’t make sense to rebuild everything because 1 out of 3 machines can’t work with it. Also, would be extensive work.
  2. Tried to apply all the tips and solutions listed here, with no luck: "Indicate Element" by Default, Not working for some applications
  3. Tried to run with or without admin rights, also no luck

Any suggestions or ideas? Let me know if additional information is needed.

Thanks in advance for all the help.


Appears my team was able to resolve this by the solution provided in your #2 solution you linked and mentioned. So, I’m not sure other than that.

I would suggest updating the .net framework though cause 4.0 seems low when most systems should be on 4.6 or 4.7.

Also, instead of using element clicks on the Ribbon, which require selector consistencies and window size, etc, I would recommend using the Alt+key to navigate the ribbons, which work on pretty much all Windows and Office applications.

So with a TypeInto, you can use “[k(lalt)]hm”

Thanks for the reply @ClaytonM

I managed to solve it in a different way.

There was no need to update the .net framework, but I had to modify all registry values mentioned here (Repairing Active Accessibility Support) to {03022430-ABC4-11D0-BDE2-00AA001A1953} in the ProxyStubClsid32 sub-key.

I also had to delete all “TypeLib” subkeys in the mentioned registry keys.

My main concern is that the solution mentioned by UiPath haven’t worked, so I had to improvise a bit, other than that, it’s fine. I’ll report in a ticket, anyways.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.