Income workflow interaktive - problem with UI activities


Everyone can some one share how do you use workflow interacetive activitie?

I have a problem that my process work if they do not have UI element.

It they do they brake on the first UI activity where I am not connected to virtual machine.

I have tried to schedule the process through Orchestrator and through Windows scheduler.

In both ways processes with no UI activities work and processes with UI activities break on the first activity.

Thanks for your help.



What kind of UI activities?

Are you asking for Launch Workflow Interactive activity? If so, it is already deprecated (I don’t remember well, maybe from 2018.4). Its task can be done on robot setttings in Orchestrator. There you can set the parameters Depth, Heigh, Width.

I had to use it once when resultion of VM was very different from the machine where I developed and tested the process, which caused some activities didn’t work properly.

I am not sure what is the exact error you are having


Thanks for the answer.

Yes, I am developing on VM and I have problems with setting up a resolution when I am not connected to VM.

I didn’t know that Lunch Workflow Interactive activity was deprecated.

I will try to set resolution in Orchestrator for one project. (I didn’t know that it can be set there - thanks for the info)

But, on second project we do not use Orchestrator. We have only one Robot and we have scheduled it manually through Windows scheduler.

I have the same problem with UI activities(e.g. click the button in the browser or typing a text into Notepad)

Also, if I run the process and then disconnect from the VM the process brakes on the first UI activity.
Furthermore, if I run the process and then only minimize the RDC window, the process brakes on the first UI activity.

Do you have any other idea how to set up the resolution without the orchestrator?


So, you have a resolution x:y in your local machine and w:z in the VM.

When you open the VM in your local machine this is opened with x:y resolution.

Have you tried to change the resolution of your local machine to w:z before open the VM and then the next step you describe?

Hi Carlos,

I am not sure how to find out what is the w:z in the VM. Also, I am pretty sure that it would not make any difference since the process fails on selectors in web browser that are not related to VM resolution.

However, it seems that when I disconnect form the VM, the resolution of VM is 0x0 or sth like that. Not sure how to fix this.

In my case occured that the process started with some navigation. The first click, apparently fine in the process, actually was made wrongly because of resizing and the next elements couldn’t be founded. I realized when I saw the screenshots.

For the actual resolution of the VM, I guess you should ask to its admin. In my case, I had into the specifications.

By the way, have you checked the screenshots? Your elements appear there or not?

Hmm I didn’t try to take a screenshots. I will try that and contact the admin regarding the resolution. Tnx.

If you are using REF, I guess your errors are System Error then screenshots should have been taken. In that case, you only have to check the folder “Exceptions_Screenshots”