In/Out argument goes back to in value

Indeed, This is a very interesting post but that is only a valid case when your XAML had an exception.
But in this scenario, there is no overloading of arguments nor an exception case but still, argument values are changing which itself is quite weird, I tried to reproduce this scenario but of no use.
Not sure why this is happening but really interested to know the root cause of this.

@Suldarie Please let me know if you are able to find out reason on same

Hi @Suldarie and @Lakshay_Verma,

InOut arguments in Studio (21.4.3) will not allow you to have default values.

I tried to replicate your issue, but I do get the updated string back to the main workflow (after the invoke).

This main workflow returned “FCT”, “WLC” from invoked workflow and finally in the main returns “WLC” which is what is expected.


  1. InOutArgumentMain.xaml (5.9 KB)

  2. InOutEditValue.xaml (6.1 KB)

A suggestion on your if statement.

Ensure when you are comparing strings especially when using .equals to use YourExpectedStrValue.ToString.Trim.ToLower or YourExpectedStrValue.ToString.Trim.ToUpper this way you ensure that the string is cleaned and formatted before using .equals

1 Like

Hi everyone,

I am coming back just to give you an update on the issue I was facing.

It seems to be a sort of a bug from the studio as going further in the process allows me to get the right Grp3 code out of the workflow. But it appears that in debug mode, going step by step, I encountered this anomaly. I don’t really know if it is a bug or not, if it should appear like that or not.

The thing is that at the beginning I really had the wrong code coming out of my workflow (that’s why I went in debug mode). Even though I still see the anomaly, now with a step ahead I retrieve the right code.

I don’t have any explanation for this but I really wanted to thank each of you for your support. This is really appreciated.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.