In/Out Argument Binding issue

Hello,

I am facing strange issue in workflow.

There are 3 arguments which are OUT parameters of a workflow.One of the value is successfully retrieved however it is getting failed for other two. Binding of the arguments are OK .Pls assist.
As per below screenshots , City2 should be Koln and country2 should be Germany.
These values are there when I am printing in the main workflow but not getting retrieved apart from Vendor details



@callsaurabh

Is both arguments are of same type or not ?

I.e Is Vendor and Vendor2 both are of same type ?

If not then change it to same type and try.

They are same. I am able to retrieve Vendor value but not City and Country.

@callsaurabh

Try to change the variable type from GenericValue to String and check.

@lakshman

No luck … Issue is still the same.

3 out variables of a Vendor_details_extraction workflow are invoked in process workflow where 1 value is retrieved(Vendor) and 2(City,Country) are not.
Those 3 out variables are getting printed successfully in Vendor_details_extraction workflow


Screenshot shown are of generic but I checkd with String as well.

@lakshman

It worked … My bad … I declared variable and argument with the same City and Country due to which it got messed up in Vendor_Extraction workflow. Now values are retrieved.

1 Like