In DU, problem with scanned documents

In DU, I can process without problems the PDFs generated by the apps, but if I scan paper documents (to PDF, previuosly) and then input them to the DU workflow (put them in the input folder), it gives the following error when performing OCR (I use UiPath OCR):

RemoteException wrapping System.Exception: Error inesperado. —> RemoteException wrapping System.AggregateException: Se han producido uno o varios errores. —> RemoteException wrapping UiPath.SmartData.Digitization.Tokenization.TokenizationException: Materiales2.pdf —> RemoteException wrapping System.Exception: Error performing OCR:

400 Bad Request

Bad Request

Captured error: Invalid page count. Should be at least 1

UiPathOCRErrorInvalidResponse —> RemoteException wrapping UiPath.Vision.OCR.OCRException:

400 Bad Request

Bad Request

Captured error: Invalid page count. Should be at least 1


Any idea of what can be the problem? Thanks

Hello @egarcia1!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @egarcia1 ,

If you are still facing the issue, Could You Provide us with the Sample Data, which gives out the Error ?

@egarcia1 Can you try by keeping the Force Apply OCR property to False in Digitize Document

Thanks superman, it’s simply a scanned (dummy) invoice, scanned to PDF with a Brother multifunctional (but I tried to scan it to jpeg and gives the same error). I try to include the PDF here… THIS IS RIDICULOUS, I’M NOT ALLOWED BECAUSE I’M A NEW USER!
Sorry it’s not your fault, but I can’t upload the pdf file. Any idea? Thanks again!

Thanks ushu. I tried that but it’s slightly different: it says ApplyOcrOnPdf, so I put it to NO. It then gives a warning telling that it will not extract data from scanned pdf files. And then, it gives another run-time error at the classifier as it finds an empty parameter (the documentText). I could put the scanned docs in a different branch to avoid the error, but I still want those documents to be processed, so it’s no solution.

@egarcia1 , Yes, There are certain restrictions for new users. However, as we move forward with the case or Interact in Forum Longer, you should be able to Upload Files as well.

We would like to Check out this Configuration. Is it possible for you to Share Screenshots of it here ?

I’m afraid it will not allow me to upload the screenshots. Which one are you interested in? I can try to describe it to you. You mean the studio with the bot? Besides, it’s in spanish, so I should translate

@egarcia1 ,

We Would Like to Know Which Activities are you using, where the ApplyOcrOnPdf property is present.

I’m using UiPath.IntelligentOCR.Activities.Digitization.DigitizeDocument (spanish version)

@egarcia1 ,

We have the Following Properties in Digitize Document Activity :


Is it the same in your case ?

Not exactly, I have ApplyOcrOnPdf (auto/yes/no) instead of ForceApplyOCR. Most of the text is translated to spanish, but this property is literal as I wrote it. The resulting argument is “ApplyOcrOnPdfArgument.Auto” in the auto case
Should I try a different OCR? I use UiPath Document OCR

Hi! Any clue about what can be the problem? Could be a bug in the spanish version?

@egarcia1 , That is what I’m not sure of, Even in the Spanish Version, the Properties of the Digitize Document Activity should be the same. I am not quite sure what is the issue.

Could you try Upgrading the Packages to the Latest Version if not in the Latest version Already.

Also, Are you able to send the Screenshots of the Properties Panel of the Activity ?

Hi! Sorry but I had to finish the demo I was preparing. Now I’m back to the problem.
I’ll paste the properties
Hope you can see them!
And I upgraded all packages, and the problem keeps!
It gives the same error, about page count < 1

Has anyone found a solution for this?