In assignment 2 advance training while saving report in destination getting error invalid character path

I am sharing screenshot where i am getting error

It just run for first month i.e January, searches if there is any report to download then navigate the URL to next WIID and extract taxid
I am getting this error :
Assign: Illegal characters in path.

Just copy the path.combine(Env…) And put it in writeline before you assign. You will come to know the issue.

I think your variables,

you need to print once to be sure you are getting correct values

Hi Team,

When i run my program individually i.e just the program System1_CreateYearlyReport i found no error and it is running but when i run the whole Main program i.e Main for the whole program of the performer then in runs for one month January then it navigate to next WIID to extract taxid.

Run the program in debug mode and keep watching locals panel. You’ll be able to track the live values of variables :slightly_smiling_face:

I guess the issue is not with the yearly report creation. I think its the monthly one.
I think the issue is on navigate-to part.
Can you print your urls before you are navigating. Add a message box or write line activity and take its screenshot

Please share the output and lets see what we have.

we have navigation of url only when reports of that particular taxid with all months are downloaded , then we navigate the URLfor next taxid .

In my case when I run my program for a particular taxid then I am able to search the first month i.e JAN then it navigate to next taxid instead of searching for next month
I am attaching screenshorts where URL navigate for first WIID then extract tax id

Then navigate URL to extract next tax id

Have you added loop on the collection of months?

Mam I have added loop for collection of months.

Can you share you xaml file? System1_CreateYearlyReport.xaml
Will be easier to tell if there is any issue.

This is my xaml file for System1_CreateYearlyReport.xaml
System1_CreateYearlyReport.xaml (39.8 KB)

I have tried a lot but not getting any solution

you have a wrong sequence of actions.
Reason, Type into and click on year is outside the loop.
Inside the loop is click month and download then your check and actions for found or not found

I am still facing issue , I have corrected the sequence as you said . Can you please share your xaml file so that I can come to know where I went wrong.

When I run my program individually it is running fine for all months but when I run my whole main.xaml it runs for one month Jan then it navigate URL to next WIID.

So please share your xaml file.

Thanks & Regards

Isha Grover

Ok, if it runs individually i wonder if its throwing some error when you are running it as a whole?
Here System1_CreateYearlyReport.xaml (26.9 KB)