Imported Namespaces are not accessible even after importing

Hello ,
I wanted to serialize a datatable to add that to orchestrator queue,so imported newtonsoft.json namespace, even though its present, its not accessible.

I’m really need a quick solution on this?Please help , my studio version is 2019


Welcome to our UiPath community.

You mean not finding Deserialize Json activity ?

No i have that activity, it says newtonsoft is not declared and inaccessible due to protection level


Can you please restart UiPath studio and then try once.


I could not reproduce the problem. I have a working SampleWorkflow using Newtonsoft.Json that I uploaded here: Http request : lost Decimals when I get data from server - #17 by lukasziebold

Can you check again?

I have manually removed namespace and tried and also restarted uipath and my hvd and nothing worked


Open the workflow with Notepad or Notepad++ and check whether that namespace is added or not.

Can you create fresh new process and try to add namespace there and check whether it’s working or not.

I also faced this issue with one namespace long back. First I tried to add it in namespace tab but no luck. Then I opened workflow with Notepad** and added the namespace manually and restarted UiPath studio. Then it worked for me.

I did the same it did not worked but downgraded uipath.webapi.activities and it worked.Thanks for your help anyway

1 Like