Import Microsoft.Office.Interop.Excel does not work

Hello everybody,
I have a problem. I want to Import the Namespace Microsoft.Office.Interop.Excel. But everytime I try it, my program stucks. And when it is working again i can not use the Namespace.

Can some one help me?

HI @fejac,
May I know the usage of this. Because in Uipath, It has many activities related to Excel.


I would like to write into a Cell of a Excesheet

HI @fejac,
Why don’t you use Write Cell Activity inside the Excel application scope . For more information about Excel you can see …


  1. Excel Automation Tutorial - DataTables Automation | UiPath
  2. Excel Automation Tips and Tricks | Community Blog


I allready did that. ButI want to use because I think it is faster.

Try this


Thanks! It is working now.

fejac, can you please share your solution? I’ve just tried: Dim xl as Microsoft.Office.Interop.Excel.Application was found in Intelisense, but there is an error, as I run the process - Type Microsoft.Office.Interop.Excel.Application is not defined… Any idea?

if not automatically added, check if you have the below name space (5th or 6th line from top), if not try adding



@vvaidya , thank you so much!!! Now it’s working, BUT!

As I will do any changes in “Invoke code”, than the part of xmlns:moie will be removed… So I need to add there this part and it’s working properly. Any Idea? But anyway, thanks a lot, you fixed my critical issue, but this “bug” could be fixed too :).


1 Like

Can you please explain where can i add excel dll reference manually