Implementation URL

Hi! I have a problem. I am trying to publish a very simple library from my Studio to my Orchestrator. So, when I click the “publish” button on Studio, it starts working compiling the programs, etc. However, at the end of the operation I recevie an error message saying “… The package cannot be published at the shared transmission.”.

I have checked the Orchestrator in the tenant setting and have seen that in the packages environment, withing the “libraries” block, I had marked the uploading capacity “only from host”. When I try to mark the “host and tenant”, it asks me for an “implementation url” that I do not know what it is. I have tried to write the path to the folder where the library is, but Orchestrator shows a red meesage saying that that has not the structure of an implementation url. So, I do noto know what to do. Could you please help me solving this problem?

Thank you very much in advance,

César

check your studiobot is connected or not .
The implementation url is the same which u used to login earlier with the machine key

Thank you very much Sree!

The not is connected to Shared folder in Orchestrator (I see it in the green button at the bottom bar of Studio).

I will try with the other suggestion.

Thanks a lot,

Hi @ccrespo9669,

When you mark custom, it only asks for the url. Can you share which version are you using?

image

Regards,
MY

Hello @ccrespo9669

I think the Robot is not connected properly to the orchestrator and the package uplaoding is not happening to the correct custom folder.

Please check the below video to make the proper configuration and to upload package to the orchestrator

The bot is connected to Shared folder as you can see here at the bottom…

Hi! InStudio, I am given these two possiblities for publishing my library. First is “Feed of shared libraries in Orchestrator”, and the one below is “Custom”.

imagen

imagen

If I choose the first one, I have the error I was mentioning where it says “… The package cannot be published in the shared transmission”.

If I choose the second one, I need to add a location because it asks for a Custom URL, which I do not know what is it…

My version in ORchestrator is

Versión 22.5.25-release.35

This is what I say. If I try to allow Orchestrator to receive libraries from outside the Host, from the Tenant, it asks me about the “Implementation URL”, what is it?

Also, if I go to Tenant → Packages → I have a button to manually upload “packages” but I do not have it for “libraries”

I fixed it. I just needed a different configuration, instead of “host + tenant Transmissions” AND “External” Implementation. It had to be, “host + tenant Transmissions” AND “Internal” Implementation…

Thank you all for your help…