Image Recording Working in Debug mode but not working in Normal Mode

Hi Everyone,

Image recording working in Debug mode but not working in normal mode. I am automating Mainframes ( from Internet explorer) did any face same issue ?


First of all I would like to know why did you choose to use image automation? :slight_smile: (you just want to practice?) If the answer is yes, please let me know what error did your received when you run the process.


Application i am working is IBM 5250 Terminal. As it is a Mainframe Application It Opens in internet explorer as Image. So that’s why i am using Image automation:slightly_smiling_face:

And you received any error when you are trying to automate?

I did not receive any error. when i run in Debug mode (Step into) it works great but when i run bot in regular mode it wont do anything. It Does first activity and next i have type into it’s not doing that. that process just ends

Did you use the type into with the simulate type property or send windows message? Can you run in a separate sequence only the type into part to see if it works? I think some delays are necessary there if is working in the debug mode. When you run in Debug mode is slower. Can you try this please? (run separate the type into part)

If I run type into as separate sequence it works but if i send any hotkey with it hot key wont work. Continues sequence of activities not working but as a separate activies they are working fine.

It is not working because it needs some delays there it looks like and some set focus activity. If you attach to this application,be sure the focus is where it has to be. Try to do some click relative into some specific fields before using hotkeys.

Thank you very much. will try those and let you know

Just need some information if how we attach existing terminal within the internet Explorer? if i can do that i can use terminal activities which will be easy for me