Image not found in a Try/Catch

Hi everyone,

I have a little issue. I’m trying to automate and application, and sometimes it throw an “Image not found” Exception and that’s perfectly find.

All I want to know is how cant I catch this exception in a try/catch activities ?

I tried system exception, find element and system but none of them worked ?



Could you please join a copy of the actual traceback?

(With a little search over internet I found Uipath.Core.ImageOperationException)

Here it is:


I find the same solution that’s why I don’t understand why it doesnt work

did you try to run it in debug mode? (F6) I’d like to see the content of $exceptionDetails (click on the magnifying glass and copy/paste the text)


Off course i tried.

Here it is.

Thanks. And your try/catch, where is it?

I delete it because i doesn’t work

could you please put your click activity inside a try/catch and set as exception to catch Uipath.Core.ImageOperationException with a warning log inside (" Uipath.Core.ImageOperationException catched by activity")

how can i set a warning log inside ?

My robot is running so I cannot make a screenshot. It might look like this.


  • ClickImage

Except Uipath.Core.ImageOperationException

  • Log Message (“I saw you”)

Except exception

  • Log Message (“that’s a fail…”)

I found th esolution, it’s a selector not found exception.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.