Image Exists not working on remote desktop

Dear Developers,
I have the project regarding auto print PDF file from customer and deploy project to RDP.
Open *PDF file
Robot find icon or pic on *PDF file with image exist.
if yes robot do printing.
if not found find next or end process.

When i try manual run from UiPath studio working fine.
But i try run from Orchestrator it’s not working.

I found something when i run project with orchestrator and remote desktop to seen robot working. It’s working fine.
but when i run the project with orchestrator close session robot can’t find image in activities Image Exists

Question : i’m not sure it’s not working when robot run on RDP right.
if yes what’s the solution to be work.

Thank you so much.

Hi @pjaiphak

Please read this article for your reference.

cheers :smiley:

Happy learning :smiley:


Are you using a community robot or a enterprise robot to run on Remote desktop?
Image activities cannot run in background , i.e when RDp disconnected state if robot is installed via.exe installer of community edition.
Find details in below post


It’s help me to understand.

Orchestrator log on it’s me.
but on RDP it’s assistance user.

Thank you very much.