I'm stuck - Build your first process with Studio (Workflow Part 1)

Hi everyone,

I’ve started learning RPA a few weeks ago (slowly…), and I’m stuck.

I was supposed to create a sequence to automate the retrieval of email attachments from Outlook, and first I kept getting an error (For Each: Unable to cast object of type “System.Char” to type “System.Net.Mail.MailMessage”).

I double and even tripled checked and I had followed the instructions on the video to a T, but every time I debugged it, I kept getting the same error.

So I just deleted the whole all the steps as of the For Each activity and added it all again. When I debugged it, I didn’t get the error message anymore, but I noticed the folder Invoice hasn’t been created, and the attachments are nowhere to be seen.

This is the version of Studio I’m using:


Sorry, too lazy to type all of it


Even if it’s not displayed in Studio, when I check the folder of the project, the folder Invoices has been created:

I must be doing something wrong, but I can’t figure out what :sweat_smile:

Thanks in advance

Hi @Paz7,

You nave cteated the folder “Invoices”, but the error said " but I noticed the folder Invoice hasn’t been created". Are you sure about the folder? Also, can you remove the "" from "Invoices" and try again ?


Hi Nikos,

Thanks for your reply - I tried doing what you suggested, but if I do that, then I get an error too:

I think we’re supposed to always write things with quotation marks (")? Anyway, in the video they used them. So I’m puzzled.

As I said, the folder is not displays in Studio, but it has been created, it’s in the project folder (I suppose as if I hadn’t specified a folder?).


Did you try going to Project Panel and clicking the “Refresh” button on the top?


yes of course should use quotation marks (") every time. I suggested to remove the \ (backslash) from the path or use a absolute path to test it

yes, no luck :frowning:
i clicked it several times

i tried removing the backslash, same problem.

what’s an absolute path and how do i use it?

Anyway, I started a new process from scratch, and it worked. No idea what went wrong