If RDP-Machine is Disconnected means Orchestrator jobs goes to Pending state

Hi Friends,
In our organization we just manually migration UiPath 2020.4 to 2022.10.7 version
But While RDP Connection is connected the process is running fine
While we disconnect RDP and run the process means it goes to Pending state?
Why it will happen we need to install any other things please let me know if you have any solution.

Thanks and Regards,

Hi @Vicky_K

Yes, When a robot is disconnected, the job will be in status “Pending” until the robot is connected again and then it’s going to run.

Check out the Link

Do you have the Unattended License to run if the VM is disconnected?

What is the Installation type of the Studio? It should be Service Mode


1 Like

yes we have 5 unattended licenses for different 5 machines all the machines get same issue.
If we open that rdp machine and run the bot means it will run but the machine is disconnected means it goes to pending state

Can tell us the installation mode in the RDP

Check out this thread @Vicky_K


1 Like


You need to make sure that while installing the Assistant, It will prompt for UserMode or Service Mode, there you need to choose Service mode installation for assistant to run the flow in Unattended mode

Hope this may help you


Did you create a Robot account with credentials to login to the machine to run jobs?

yes we done it

And the Robot account and Machine are both assigned to the folder from which the Process is being run, correct?

Yes, It will assign it same folder


Did you Input the Windows credentials to run as Unattended?


Are you using a Machine or Machine Template? The upgrade to v22.10.7 was done on the robot PC? And it’s connected to UiPath Cloud?

@Vicky_K could you also try Signing Out from the VM, instead of just disconnecting the RDP session? Might be a currently connected session is blocking Orchestrator from opening another one.

It won’t show while install the studio but we have advance option there we can choose Service mode i will change to service mode it will run Thanks you for all giving the solution

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.