IE Issue after upgrading to 18.3

I am also facing the same issue after it upgraded automatically.
I uninstalled UiPath studio installed but it automatically upgrades to 18.3.0

Is there any way to downgrade the version?
Please suggest I need it urgently.

Thanks in advance.

those who have this IE open browser issue, can you do a clean install of 18.3 ?

Uncheck “Enable Enhanced Protected Mode” in Internet Options


@Gabriel_Tatu already tried a clean install after removing the old version. Didn’t work, though

Did @Dan_Munteanu’s solution worked for anyone? I can’t uncheck that option due to the company policy we’re working on.

@Renan_Kataoka With this option enabled IE runs its tabs with high integrity mode (AppContainer level), this option applies only to x64 IE. If you can switch back to x86 IE, automation may be restored too. There is another checkbox in the internet options advanced tab which toggles 64 bit IE.

My previous question was not answered.

Now I have a new issue, Whenever I start Studio it shows “One or more error occurred. Please restart the studio”. I did the same more than 5 times but problem persists.

I think downgrade will be a good option. Please suggest the way to do it.


can you show me that error screen?

sure. here it is
Here is the first screen after starting

Here is the screen after pressing Ok

Any Update?


Hi Gabriel, I’m facing this same issue with Chrome. One thing I noticed is that when I tried re-installing Studio version 2018.2.3, at first it didn’t work, but then I uninstalled the extension and re-installed through Studio and it started working again. However, when I opened my project Studio auto-updated again and then the problem came back. I uninstalled the extension and tried to re-install through Studio (2018.3) and it gave me a message saying that the extension was already installed for the user. I’m not sure how to get around that one so I can try re-installing the extension through the new version of Studio. Any Ideas?

I was used more solutions, but I can not comunicate with IE

When I using web record and open browser. but show error

Studio 2018.3.0 - 10/01/2018
Community Edition
EXE Installer
Expires in 11 weeks
Device ID: ZZ34K4YTo2aKosbNVx5e
Update Channel: Stable
Microsoft Windows 10 Pro 64-bit
.NET Framework Version 4.7

In studio log

[ERROR] [UiPath.Studio.exe] [1] UiPath.Core.ElementOperationException: Error HRESULT E_FAIL has been returned from a call to a COM component. ---> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
   at UiPath.UiNodeClass.Get(String bstrAttr)
   at UiPath.Core.UiElement.Get(String attribute, Boolean refresh)
   --- End of inner exception stack trace ---
   at UiPath.Core.UiElement.Get(String attribute, Boolean refresh)
   at UiPath.Workflow.Wizards.OpenBrowser.Init(UiElement element, UiElement topParent, Image image)
   at UiPath.Workflow.Wizards.RecordingManager.InitRecordingStep(RecordingInfo recordingInfo, UiElement element, Image image)
   at UiPath.Workflow.Wizards.RecordingManager.RecordStep(String wizAction)
   at UiPath.Workflow.Wizards.RecordingManager.ProcessWizard(String action)
   at UiPath.Studio.Workflow.Wizards.ViewModels.MainWizardViewModel.OpenWizard(String action)

Me too. When I run with administrator permission, I can be using web record, but still can not communicate with IE.

We are using 2018.3.2 and it worked a couple of days ago but after installing this windows update: KB4462917(
we got problems automating both Chrome and IE. It will not give access to each individual element in the browser now.
I have tried all of the above without luck.

Please help


Encountered the same issue today, both the “Cannot communicate with Internet Explorer browser” and “Step was not recorded successfully”. During the weekend, our Windows 2016 Server had received some updates, this is the only thing that has changed since Friday when UiPath was still working fine with IE.

Hello @tuokyh,

It seems that you have some broken COM settings on your machine that prevents Active Accessibility to work correctly

Open an elevated cmd.exe command line and execute:
regsvr32 C:\Windows\System32\oleacc.dll
regsvr32 C:\Windows\System32\oleaut32.dll
regsvr32 C:\Windows\SysWOW64\oleacc.dll
regsvr32 C:\Windows\SysWOW64\oleaut32.dll

Additionally, check Windows Event Log for a similar message:

  • WindowsUpdateFailure3, “Device Driver Retrieval Client”
  • Application Crashing Events, Faulting application name: IEXPLORE.EXE
  • UiPath Executor Error: Execution failed

Windows Updates which include changes in programs used by UiPath Robots (like IE, for example) should be done while the Robot is stopped or paused. The Windows Update service trying to change a program and the Robot trying to run actions on that same program may result in conflicts difficult to predict, analyze and resolve.


Any update on the error “Cannot communicate with Internet Explorer browser” triggered by Open Browser activity? With Chrome it works, but not with IE.

I’m using:
IE11: v 11.407.17134.0,update versions: 11.0.95 (KB4466536)
Win 10 Enterprise, v 10.0.17134 build 17134
UiPath Studio Community 2018.4.1, Win 10 64bit, .NET framework 4.7.2


Hi All - I have the same error where it says “cannot communicate with Internet Explorer browser” in addition to a Windows 10 upgrade, the UiPath Studio was also recently updated. All other actions work except those with IE.

Any help would be great - thank you!

Reading through here, it looks very similar to an issue I had that wasn’t related to 2018.3, but is instead due to permission levels. Instead of using the “open browser” activity, open the browser by having the robot send the command windows key+r and type in (without quotes) “iexplore”. Then attach the browser that opens and continue as normal.

If it works, it is because the robot is running as a service with elevated access. When it sends a command to open browser using open browser, open application, or start process, it is starting it in elevated privileges. Then, when it tries to automate/manipulate the applicacation it does so at a non-elevated level.

The only fix that we could find was to give very specific elevated access to the user running the robot, or to open programs manually using windows key + r, or navigating through file explorer and running the application executable.

1 Like

This worked - thank you very much!

After trying all the above possibilities (register DLLs, change Internet Settings) the solution was to run UiPath as Administrator.
(Request your company IT if necessary).

1 Like