IE: Clicking in a frame link

Hi!

I’m new in uiPath. Hope you can help me with a recent issue :wink:
I am connecting to a web site (IE) it has a frame in the left site and the recording is not caching the full URL link. I have been trying to change it but I am not able to set the selector properly.

Here how my selector looks after I used the recording:

When I checked the Link url --> link–> https://www40.interaction.bell.ca/portal/template.jser?tpl=content_apps.tpl&id=103

I also can get the element from IE:

How can I change the Selector script to point to the id 103?

This is what I get from the recording:

Each time I tried to change it and getting errors.

Thanks :slight_smile:

@sacv2 Welcome to the community!

I may not be understanding properly, but, I don’t think you need the link - just use the ‘Click’ Activity for that selector.

Regards,
Z

I am using click but it is not working

image

@sacv2

Could you please try with Click Image or Click Text Activity and Specify the text in double quotes you want to click it.

@sacv2 Ah, you updated your post from the original that I read. Looks like your selecting only the FRAME? I read tag=FRAME

Did you validate?

Removed line - realized is a portal site with login

Yes for some reason is taking always the left frame but can not find the proper link. Yes I validated it.

Yes it is a portal site with login

Thanks

I tried Click Image but it didn’t work I will try it again :upside_down_face:

Since we cant see the site, any chance you can get a screen shot of you choosing the selector (using UI Explorer) and the Selector Editor Validated results? Maybe we’ll see something.

This is the output after recording:


This is the selector editor:
image
This is the UI Explorer:

and also if I do Inspect element I am getting for that link:

What I can see the selector is pointing to the left frame but it is missing the link ID - it is 103 but when I tried to add it I am getting validation errors

This is part of why I wanted a SS to see the actual selection, ie. when you’re moused over the link you want to click). The reference image in your SS above makes it seem like you may not selecting the actual link. That being said, it seems like you’re expecting the URL to be somewhere in UI Explorer Selector and there’s a good chance it won’t be.

Keep in mind, the selector you choose is just a way for you to describe to the UI Path how to choose which element to select; to click - which means it probably wont have the actual link to select. You’re just trying to simulate clicking on an element and the UI Path selector is simply the address to point the mouse, and trigger the click event. It may look nothing like a link depending on how it is coded - so it probably wont match the final URL or event a Mozilla Developer Tools inspect element - so you may be misunderstanding the href and its meaning in this context.

i.e. I have this page:
http://www.maths.surrey.ac.uk/explore/nigelspages/frame2.htm

and I use UI Explorer to select the “Tables” link and get

image

but if I get the actual link by hovering over, it is
http://www.maths.surrey.ac.uk/explore/nigelspages/tables.htm

But that link shows nowhere in the selector - but when I run the above click activity with the selector like the image, the bot properly clicks on the link.

So, you should not be worrying about making anything match the link, like id?103 or whatever - just use the selectors and it should work. That’s I mentioned in the beginning - you don’t need the link. This is being handled server side; simply emulate the click. UI Path simulates a person interacting with a session by clicking on things and typing into boxes, etc.

Ok Thanks

This is the site, I want the click under Billing:

After the click I should see this:

Thanks for you help

Ok, but, did you try again from scratch? Your original post made it seem like you clicked on the element to get the selector elements, but upon seeing the recording “is not catching the full URL link” edited the selector to try and include the URL, ID103, etc. You said, " I have been trying to change it but I am not able to set the selector properly."

Have you tried, “Indicate Element”, selecting Billing, clicking “OK” (without changing anything) on the Selector Editor Box and running the script to see if it clicks on the button/link.element?

Yes, I did it but when I am running stopped here

Ok, because in your screen shot, the red box around the image in Click “FRAME” seems to be around the entire “Online Services” element rather than surrounding only the billing element.

If you have verified that you click, and UI Explorer picked up, only the Billing selector element, then, without having access to the site to see what is happening, I’m not sure what more advice I can give.

Thanks for trying I know it displays “Online Services” I think it is because it is only 1 frame but I am 100% sure I clicked in the billing link when I created and I also I created all steps from scratch without the recording but always it stopped here.

I have added some validations to see if it can find the text Billing but I am getting False. Anyways when I find the solution I will let you know :slight_smile: This web site has something different :wink:

I did it with others websites and always it is working.

Thanks and regards

@sacv2 - You bet. Sorry I couldn’t help - I thought we were almost there, but you were on it - seems to be an issue with the site.

One other options is to examine the “Unselcted Items” in UI Explorer, and add some of those aqnd see of that helps zero in for where the bot should click. ie.

Things that help zone in like class and tag etc., adding them may help zero into the specific spot you need.

If I think of something else I’ll post back.

Ok I was able to figure it out. It is an issue with Microsoft edge for windows 10 it is not working properly. I recreate the bot by using Chrome and it is working fine. Also I have recreated in a windows 7 pc and it works as well. Now I need to find a solution for my IE in windows 10.

Regards.

1 Like