I want to run my script from cmd. Can anyone please tell the end to end process


#1

Hi,

I have a script. I should run it from command promt.

Ex: Opening a web browser.

In cmd when i copy
C:Program Files (x86)\UiPath Studio"UiRobot.exe. I’m getting invalid directory name.

If i copy below in
C:Program Files (x86)\UiPath Studio"UiRobot.exe"/file:“D:\Venky\Ui Path\Ui Path Xaml\CmdTest\Main.xaml” in RUN it is throwing error.

Urgent please do the needful


#2

Use This command to run the robot…

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”
/file:“C:\Users\hemachandiran.k\Documents\UiPath\RPA challenge\msg.xaml”


#3

Thanks
Where i need to copy this command. Can you please tell. Will it automatically run the script


#4

Open your Command Prompt,
It Will Open By the Default Location "C:\Users\username"
And Copy the below Command and press enter

It will show the same Location after enter the above code

And Then Enter the Below code

It will work…
Make sure that the Double quotes and Colon are same as I mention Above


#5

Yes I tried but i’m getting Invalid filename or directory name


#6

image


#7

Hey @ravi1

Go through with below link:

Note - For 2017.1.* version Uirobot.exe will be at “C:\Program Files (x86)\UiPath Platform\UiRobot.exe”

Regards…!!
Aksh


#8

I am Using the same command,It will work…

Check Whether your file is in Correct Path


#9

Thanks. Working


#10

Hi, @ravi1
Can you tell how to recover the Error Invalid filename or Directory name…


#11

Same as Poovarasan said.
Copy after entering command. Do not give cd\ or cd…


#12

Thanks…


#13

Thanks aksh.

It is working now in my system. My use case is to run command prompt from my system and script should be running in other system. We are not using orchestrator.

Thanks in advance. Please suggest


#14

Hi @aksh1yadav @Poovarasan2,
I want to run the UiPath script through command prompt.Its working fine using above commands. But when I used mysql database activities (as well as excel activities) and connection in uipath workflow its showing error.I am using Uipath studio 2018.2.3
Can you please help.

Thanks in advance.