I want to relieve a file from UiPath Robot Executor

I copied a file from source folder to destination folder.
Later, when I am trying to delete the file in the source folder, it get a message that “this action cannot be completed because the file is open in UiPath Robot Executor

Please find the Image Attatcheduipath executor


I guess still robot agent is running and you are trying to delete the file ? Am I correct ?

If yes then stop running BOT and then try once.

Yes, you are right.
Still Robot Agent is running while I am trying to delete the file.
If I stop running the BOT, I am able to delete the file manually.

But I want to delete the file through the bot

1 Like


Once you copied all files ang give some delay and then try to delete the files. It should work.

Alternatively you use Move File activity to move files from source to destination folder and then you no need to delete files from source folder once copied into destination folder.

I have tried to give delay of 1 minute, still the file can’t be deleted.

I know about the Move Activity, but I want to use Copy and then delete for some reasons

1 Like


Anyways you are trying to delete the files immediately right after copying the files. So I suggested to use Move File activity.

After copying files use Kill Process activity and mention process name of PDF reader using and then try to delete files.

As you said you have some reasons to copy and delete it
Can you try Below steps ?

  1. Copy the file from Source to Destination path
  2. Move the file from Source to Temp Folder
  3. Delete in Temp Folder

Let us know for any further help needed :slight_smile:


I haven’t tried this. Let me check, I think that I won’t be able to move the file as it is in use.
The Process which uses the file is the Robot itself.

Ideally the Robot should relive the file as its operations are completed.
But I will check it…

Hi Pranav,

Even I have faced the same issue before.
You can use powershell commands to delete or move the file.

It works perfectly for me.
This might help.


1 Like

hi @karthick,
I was also facing the same issue and tried the ways suggest by you. but it didn’t work out for me and powershell command also i have used to delete the file. no luck on that as well.
Could you please suggest any other solution?