I have problem with IMAP

I can’t get imap messages from gmail account. Error
“Invalid Credentials (Failure)”
I can’t attach screenshots.

In my experience, when using Gmail, you need to go into your google account in the security area and enable access to less secure apps.
At least that’s what I did for a personal project, but I don’t think it’s the best solution for a bot that will run in production, and I don’t think you should leave your gmail account accessible in such a manner without need, because it’s less secure.

1 Like

Hey @rpa6 ,
for gmail you have to enable IMAP on your account settings:

  1. Sign in to your Gmail account by using a browser that is supported (Google Chrome, Firefox, Internet Explorer, or Safari).
  2. Choose or click the gear icon (Choose the Gmail gear icon.) on the top right.
  3. Choose Settings > Forwarding and POP/IMAP .
  4. Select Enable IMAP , and then choose Save Changes .

Don’t forget to switch on the ‘less secure apps’ option:

  1. Click Security > Basic settings .
  2. Under Less secure apps, select Go to settings for less secure apps .
  3. In the subwindow, select the Enforce access to less secure apps for all users radio button. …
  4. Click the Save button.

For IMAP properties please use port 993 and server imap.gmail.com.

I think it will help :slight_smile:


works for me

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.