I faced an unknown issue when sending the Argument values to another XAML file

Hi All

I built the bot in the Uipath studio version 2019.10.4, and I added a new XAML file (API) after I upgraded the Uipath studio version to 2020.10.10. I use the Arguments to send the values to the new XAML file. I can see the values in the local panel, which I send to the new XAML file.

The issue is, the API in the new XAML file did not work if I sent the values to the arguments to the new XAML file.
If I hardcode the values in the Arguments section, then the API is working.

The values I sent via the Arguments and the hard-code values are the same.

The interesting part is the API did not work if I sent the values to the Arguments. But the same API worked when I assigned the argument to the same argument name.

For eg,
arg_abc, arg_def, arg_ghi
HTTP request activity with all three arguments.

By following the above steps, the API worked, and I received the API response.

It’s not a valid issue. It’s difficult to find the solution for these issue types and the tricky challenges.

Please share your views. What could be the reason?


Most likely you have a misconfiguration in your arguments like an in argument not being set to in or a wrong name and the value is lost. Please share the workflow where you run into this issue.