I can't send screenshoot in e-mail body


I have problem with sending e-mail with screenshot.
I use google workspace activities.

  1. I take screenshot with “Take Screenshot” activity
  2. With using file path I create variable imageBase64=Convert.ToBase64String(System.IO.File.ReadAllBytes(ImagePath))
  3. In e-mail body I write:

I receive e-mail but picture is blank - picture with border and blank background

@Patrycja_Cwikla are you saving screenshot with right method?

@raja.arslankhan What does it mean in right way.
I did it like that

I saved image as png.

Main.xaml (35.2 KB)

Please try this. It is working for me.

@Patrycja_Cwikla are you able to open it manually and see it is in correct format

I don’t want to have this image as an attachment

Yes, I am able to open this format

Hello @Patrycja_Cwikla

You can use Create Html Content activity and create the html syntax to add the image. Can check the below video.


Kindly note about the direct conversion option:

then we used:
"<IMG src='data:image/png;base64, " + myBase64String + "' />"

kindly note where ; or : or , was used.

It was working at our end

I use html content activity and I add screenshot from desktop.
I see this image in this activity

But in e-mail I see this

Plz cross-check the html content generated with this activity.


I receive

but here we do see the dependency to the file system which will not work e.g. at the receivers end

We would again refer to the above mentioned direct approach

Are you trying to send an image which is there in sharepoint?? Can you try with a local file?


It was local file
I tried with image in clipboard also and I received. In e-mail image from clipboard is also blank

You probably have File selected. You need to select Image, as @ppr showed:


Just copy this html tag and paste it to notepad and save that file as .html. Then check how yhe image is coming.

If image is not available, then change the filepath in the src attribute.

For example: src=”C:\photos\demo.png”

That won’t work. The file will be on the computer the automation is running on, and won’t be available to the user who receives the email.

This is just to check the syntax… I doubt the path she provided is having some error.