I can't put a property into the selector cause it's not in the "Selected Items" in UI Explorer?

Hey there,

I want to know how I can choose a property that is not in the selected items list, but in the Properties Explorer, in the selector…

I tried to see all the elements in my program, but the property I’m looking for doesn’t exist in anymore elements. This is the example:

I want to select the element, by if the element is visible, with the property “relativeVisibility=True”… But I can’t put this property in the selector, cause it only works if the desired property is in the “Selected Items” list…

I tried writing directly in the selector, it didn’t work.
I tried browse all the elements to see if this property was in their Selected Items, it doesn’t work… I don’t know how to pick it.

Cheers

In the above UiExplorer change the UiFrameworks to either ‘Accessibility’ or ‘UiAutomation’ mode.

it will give you more attributes to work with.

Unfortenaly, it didn’t work :(:slightly_frowning_face:

Well, Can you share that URL let me check once…

Hey, @Raghavendraprasad, it’s not an URL. It’s a SAP window.

You should have told that first int he question details. SAP means go into the help section of your SAP app and try scripting. Sometimes SAP elements are not recognized.

It was already done.


Is there any other option?

I have same problem with SAP. Uipath does not allow me to use properties/attributes (like “text”) in selector , they don’t show in UiExplorer right side “selected items” but I can access them (for example “text”) with Get Attribute activity. But looks like I have no way to use them as selector… any idea how to go around this?

Hey, any updates on this? Has anyone found a solution to this? I’m looking at SAP and including some properties not listed too. Any help would be appreciated, thanks!

I also have the same issue, did anyone find solution