I cannot seem to copy and paste multiple sequences to another xaml file properly

I have multiple sequences joined, however when I copy them and try to paste them in another xaml file they always get pasted in a messed up order. Or I have to paste them one by one. Is there a more efficient way to do this?

Hello @Mayur_Pande,

I have faced this problem too, what i did.
I opened up two instances of uipath, then I copied from one and pasted in another xaml file of another uipath instance.

For example,
one instance has Main.xaml file, from here I am copying it,
another instance has LoadDataInSap.xaml file, I m pasting in this file. this way i succeeded,

Cheers,
Pankaj

1 Like

Hey @Mayur_Pande,

One other thing you may want to consider is the order of selection. If you select by window from the bottom up, they will paste in the reverse order of what you expected. Control click on activities should paste in the order selected.

But ditto on @Pankaj.Patil suggestion to open two instances of Studio. That should definitely help.

Cheers!
Troy

1 Like

Thanks @Pankaj.Patil and @tmays will definitely use both of these methods!

Hello @tmays,

Even if you sequently start selecting and copying them, at the time of pasting they may get reverse order.
I tried this.

Thanks,
Pankaj

1 Like

Thanks @Pankaj.Patil. I guess I haven’t run into that issue specifically so I stand corrected. :slight_smile:

@tmays @Pankaj.Patil Tried both way, they both seemed to past exactly the same way, only one sequence was out of place! Very random maybe a bug they could fix.

@Mayur_Pande

Makes me wonder if it depends on the order they were initially placed into the workflow. It also makes me wonder if they’re cleaned up (rearranged) if you were to publish first and then try. If I have time I’ll test that theory.

Just thinking out loud here.

Have a good one.
Troy

Hello @Mayur_Pande,

try copying more 5 activities and paste them in workflow. they may get messed up at least one or more activities.

Cheers,
Pankaj

Hey guys,

I have the same problem that the order of the activities get messed up if I try to copy a couple of activites into another sequence. Is that a bug of the community editon?
In my opinion, it wasn’t like that in the earlier versions.

That is a very frustrating think. Does anyone found a way that works constantly?

Thanks a lot!

HI @Akimbow

We’ve spotted this bug and it will be fixed eventually.

In the meantime, I would suggest a semi-workaround. If you temporarily place the activities you want to copy inside a sequence, they should copy over in order.

It’s an additional step, but should do the trick for now.

Thank you for response.

But if you have a big sequence with many activities and you just want to copy a few of them, the workaround won’t help. If you copy them temporarily into a sequence they will get messed up in the same way.

I hope this bug will be fixed in any case and not eventually, because it’s a bug and in earlier versions it did not occur. :wink:

2 Likes