I can no longer select elements (just shows whole blocks)

Hi, what could be the problem, if UiPath no longer identifies separate Elements (e.g. icons in ribbon)?
It only selects the window as a whole.
Thanks

Edit: I tried without success to run as admin, reinstallation, different version of the UiAutomation package.
selector

Hi @Jizh

What sort of an application are you trying to automate here? web application or a desktop application?

1 Like

Hi @Jizh,

Great…! So If you are using desktop applications, almost all the applications will have their fields, icons and buttons readable/accessible, that is we will have selectors to access them. But if you are accessing any element in a web application, you may not have access of a field, icon or button with selectors, because the one who developed might blocked the access.

so the solution is,
for the first case…you can select an element for sure. To other extent if you are not able to access the element, you can make use of Find image activity to find the icon.
and this is applicable or second case as well.

Additionally, run the uipath studio as admin that elevates the permission to access the element with selectors in different applications

Hope this would help you…For further more details please refer this,

Cheers…!

1 Like

Thank you for the suggestions :slight_smile:
The thing is that it is a desktop automation and it affects all kinds of elements (also desktop icons, etc). All that was previously no problem to identify and it also works on other computers. It happens in Studio and during execution. I tried with admin rights but it didn’t change.

In UiExplorer, the framework “default” doesn’t work but “UI Automation” works. Has anyone had that problem before?

@Jizh
Buddy does image activity work with that…

Cheers…

@Palaniyappan Thanks for the reply. What do you mean with image activity? OCR?

Yes buddy…!
As you say the whole window is getting selected when trying to select the element, you can use image activities like find image or click image, etc

Cheers…!

Well, this is not really an option as it worked normally before. It’s not Citrix but a normal Win10 PC and there should be some way t make the text activities work again.

@Jizh
Buddy image activities are not only meant for citrix environment, we will be having certain web application or even desktop application where for certain elements you wont be able to access its attributes, in the sense the developer of that application might disabled that feature…So in that case we can use image activities, For example you can check with desktop and even basic recording wizard, we will be having an option for image picking as well…
Hope it would help you

Cheers…!

1 Like

@Palaniyappan
The problem is that it’s not only for a certain application, it’s for everything, including selectors that work without a problem on other PCs. I might just need to wait for the UiPath support but it’s always a very slow process…
Thanks

1 Like

Bro where you able to find a solution for this, even I am facing same issue.

Thanks,
Hari

1 Like