I am unable to run Bot on client machine. It is showing error

While I am able to run Bot from studio and Uipath assistance both but on my client machine it is showing error "Could not load file or assembly ‘microsoft.sharepoint.clinet, version=, Culture=natural, publickeyToken=71e9bc111e9429c’ or one of its dependencies. The System cannot find the file specified. "

We are not able to install this missing packages manually as well.
My client has installed Uipath community version and Assistance.

Hi @patidarsumeet1,
Can you please show some more details? Some screenshot, configuration etc.

How is your client Assistant configured? From where this process is being started? How settings are looking like? Without more details I can’t see where the problem might be located.

He has downloaded Community version and installed the same. He has windows 10 pro. This all Bot showing in screen shot are attended BOTs so triggered manually. We have used UipathTeam.Sharepoint.Activities in our solution. This is causing the problem I think. But it is working fine on my machine I have enterprise addition of uipath. Please resolve this problem as I am unable to give demo to my client at his machine.

Is he connected to Orchestrator or the package is published locally and trigerred from the Assistant?

Package is published locally and triggered from the assistance.

Is the machine connected to the internet?

yes, We do the screen share over call and try to execute the same.

Based on the error it looks like either the process can’t contact with the Sharepoint (is it installed?) or there is issue with a dependency. Is the same error occurs when this process will be started from Studio?

Yes. Package for SharePoint is not getting installed automatically or manually as well. We have tried to download it manually as well but no luck. It is keep causing problem.

ensure following:

yes this both are checked. only we have one difference instead of “Go!” it is showing “Marketplace” , But Url is same.

Could you please try to reference your required dll of sharepoint from Imports in studio and republish package.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.