I am not able to download Ui Path from the link provided.....the page is not being loaded inspite of good internet connection, pls help

I am not able to download Ui Path from the link provided…the page is not being loaded in spite of stable internet connection, pls help

Could you share the link you are using? What error is being displayed?


This is the link

This URL seems to contain a token for authentication which is not yours - if you try → https://cloud.uipath.com it should send you to the login page. From there you should be able to login and download the studio from your cloud tenant.

Still the same issue…from the link u provided. It’s just loading and loading in spite of a stable internet connection.

HI @Garima_Soni

Can you try with a different browser?
or try clearing your browser cache and see if that works?

  1. Cleared browser cache
  2. Tried different browser

Still not working

Hello Garima,

I have checked the portal (cloud.uipath.com), it is up and running for me.
I suspect there could be some connectivity issue while you’re trying to access the link. Here are few suggestions if you haven’t already tried.

  1. Try to open the URL in the Private/Incognito window.
  2. Try with a different internet connection.
  3. In case you are connected VPN, try to access the URL after disconnecting it.


One more hint, please do try to check if your system clock is correctly set, including the timezone. It can sometimes cause some issues as well.

Yes its right, still not working for me

Hi @Garima_Soni,

Have you tried restarting your machine? And if that doesn’t work try accessing the cloud portal from a different machine and see if that works for you.