Hypelrink Excel Uipath

  1. In my datable starting cell is A4.
  2. L4 ,M4 columns needs to be hyperlink.
  3. I have implemented using string manipulation.
    4.The value “YeS” wiuth hypelrink is coming but not having the path in it.

Please help.


The hyperlink value “YeS” that you are getting in UiPath is not having the path in it because you are using string manipulation. When you use string manipulation, you are only creating the text of the hyperlink, not the actual hyperlink itself. To create a real hyperlink, you need to use the HYPERLINK function in Excel.

When you writing in cell with write cell activity use formula to convert that text as hyperlink

In cell L4 of your DataTable, enter the following formula, for example

=HYPERLINK("https://www.google.com", "YeS")

Cheers @Ritaman_Baral

Let me try it then…lets see the results

1 Like

not working …i tried…

in add datarow I am trying to add the command
its not working


Are you using datatable to write the data?

If so you need to use write range from excel…if you are using workbook write range it would not work

Also double quotes needs to be escaped


with variable - {"=HYPERLINK(""" + Path + """,""Yes"")"}

Basically you need to use excel activities and not workbook activiites


Try to cover your same statement with double quotes for all string used within that statement

Have a view on this example


The last row is opening the path…the rest other path is just blank.

not working…i tried just now


Can you please show what you tried

Some screesnhots will help identify the issue


the variable syntax that you shred…


Where did you use it? in array row?

or in any other activity?

:slight_smile: because I used the same and it is working…so wanted to check the difference…if you sue in write cell then you dont need flower brackets


actually i am working in vdi…
I have used it in add data row activity…and then using excel application actvity to write.

See the pic…the last row is red…it is having the path…the other rows are simply “YES” with a hyperlink…

The issue is ,

the last row is working with hyperlink…the pother rows are not


Can you show screenshot of the value exactly that is written in other rows…

it cant be like it would work for one and not for others…may be the variable is empty also might be an issue


YES for the one which is not working and the path is reflecting for the last one


then can you please check your variable…looks like the variable is having a wrong value…better use a log message and print it and check what is being written


okaay…let me try it…

1 Like

the variable is having correct value…just now I checked…

But anyhow it is only writing properly on the last row…


Please check the issue…Becaue I tried the same just now and no issue