Http request login


#1

I am currently in the midst of trying to access the API of orchestrator with the http request activity in uipath.

I have tried in all the possible ways I could imagine to get access but to no avail.

End point: https://COMPANYURL/api/account/authenticate (I have also tried with the normal browser login URL)
Request method: POST

I the documentation for the orchestrator API they mentain a tenancyName - I have no idea of what that is, and is does not show up when I usually log in.

Also, do I parse log in information through the parameters?
so:
tenancyName : ???
usernameOrEmailAddress : user
password : secret

All I get is this when trying log URL:
{
“result”: null,
“targetUrl”: null,
“success”: false,
“error”: {
“code”: 0,
“message”: “Username cannot be empty.”,
“details”: null,
“validationErrors”: null
},
“unAuthorizedRequest”: false,
"__abp": true
}

And this when I use the one from the documentation:
An error has occurred (with status code 500)


#2

Hey @Lenz

Please go with this link and you will get understanding on it :slight_smile:[quote=“Lenz, post:1, topic:7106”]
a tenancyName - I have no idea of what that is, and is does not show up when I usually log in.
[/quote]

it will be your login username in Orchestrator.

The term “software multitenancy” refers to a software architecture in which a single instance of software runs on a server and serves multiple tenants. A tenant is a group of users who share a common access with specific privileges to the software instance.

See above from here what you will Enter that will be use here in tenancy name.

if still you will face some doubts or issues, let me know :slight_smile:

Regards…!!
Aksh


#3

The thing is, when I log in, ‘Tenancy name’ is not even an option for me. Tried filling out the same from the link, still got error status code 500


#4

What version of Orchestrator u r using?


#5

So you might have Old Orchestrator version. and Orchestartor api Version is 2016.2.*


#6

Version 2016.2.6274


#7

then why not came for you tenancy name ? are you an admin user?
Rest @badita @Teodor_Hoaghea can let you know :slight_smile:

Regards…!!
Aksh


#8

Multitenancy is optional and needs to be enabled. Not everyone uses it :wink:

@Lenz - a guess - can you try putting “default” (literal text) as the tenant?


#9

ahhh was not aware with it? how you can make it disable then? and with api tenancyname parameter is mendatory? right? @andrzej.kniola

Regards…!!
Aksh


#10

You could revert the setting (check Orchestrator User Guide -> Multitenancy for which one), but I’m not sure what that will do with your data (probably you’ll just lose access to it, but don’t quote me on it) :wink:

Not sure if it’s required for API calls (we’ve always used multi), but IIRC the “default” tenant is there from the start and is used… well, by default, so it’s a high percentage guess (but still a guess).


#11

I have succeed calling …api/account/authenticate and get a token back from the server (orchstrator) then i use the token in a call where i try to call https://OURDomain.XX/odata/Robots?$filter=Name eq 'XXXX’
Im using the http request wizard, method GET, response JSON. But the response is an 404


#12

Hey @Lars_Ringe

Are you also passing Bearer Token as well?

It should like this :smiley:
You have to pass token as well in headers like this :slight_smile:

Regards…!!
Aksh


#13

I got a new error message now:


An error occurred

    <a href="/Account/Login">
        Login Page
    </a>
</div>

#14

I think your token has been expired.

Note: By default, the bearer token expires after 60 minutes. You can change the expiry time, by modifying the value of the Auth.Cookie.Expire parameter, in the Web.config file.

Regards…!!
AKsh


#15

yes im aware of that. that is why it took me an minute extra. I had to generate a new token before i tried Again


#16

Modifying the expire parameter must be at the server side. On the host of Orchstrator


#17

Beware of that my token i fictive


#18

You should have a “default” tenant. We’ll get back with some examples for calling the Orchestrator API.


#19

Hi,

I have a created a tenant in Orchestrator and when I clicked on login it shows a blank page. Can you please help me out in resolving the issue


#20