HTTP request gives no output when calling for RESTful Rossum Elis API

Hello, everyone
Yet I have not used APIs with UiPath. But I was in need to integrate one service which is being discussed on the forum (Rossum Elis Data Extraction).
I was following instructions provided here (https://rossum.ai/blog/automating-data-extraction-from-invoices-using-rossum-api-and-uipath/) that seem pretty straightforward.
I signed up for an API authorization key and assigned uploadEndpoint = “https://all.rir.rossum.ai/document” , as it stated in specification.
After i launched the robot it failed at the Extract ID activity inside Upload State, saying "Extract ID: Object reference not set to an instance of an object " .
Investigating it i understood that HTTP request activity which output is ResultJSON came in empty.


I tried Rossum’s template PDF which i found here (https://github.com/rossumai/elis-client-examples#example-data) to understand if it fails with my PDFs only but, alas, it did not succeed as well.

Is there any workaround in that case?
Just in case here’s xaml file RossumUIPath.xaml (56.8 KB)
Thank you

1 Like

Hi

I have got this working, and have had exactly the same issues as you. Basically whats happening is nothing is being sent to the api as something is missing or wrong that’s why its failing at that point as there is nothing in that variable which is the output.

First thing to check is your authkey assign is set correctly in the initalise step it has to have “Secret Key” before it

image

Make sure you have all these packages as well
image

Check this first and we’ll go from there

Hi, @Jersey_Practical_Sho
Oh yes it did work my bad I did not notice the additional secret_key at the beginning.
Have you encountered situation when after launching robot “Execution has been cancelled” message appears?
Funny thing that after placing Message box that problem was resolved, although it’s still not stable and you can get “Execution has been cancelled”


Have you ever come across this? And how do you bear with NA values in your CSV file after parsing?
Maybe i should consider using another language in my endpoint API, although it works just fine when using rossum java script client to test invoice on their website.
Thank you

I’ve not come across that message box as of yet, I only started using this yesterday as we have been researching invoice processing api’s.

Im not dealing with the N/A’s at the moment so haven’t needed to worry about them too much

Take a look at Datamolino they have a very similar system, also with web based and api’s.

Keep me update with how you get on in the future

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.