HTTP Request breaks the process - Cannot create unknown type HttpClient

robot
activities
studio

#1

I use the HTTP request activity to make a post request to an API but RPA job fails when it is started via orchestrator. Same RPA job runs without any problem in Studio.

Execution error : System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}HttpClient’.\r\n at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)\r\n at System.Xaml.XamlWriter.WriteNode(XamlReader reader)\r\n at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)\r\n at System.Activities.XamlIntegration.FuncFactory1.Evaluate()\r\n at System.Activities.DynamicActivity.OnInternalCacheMetadata(Boolean createEmptyBindings)\r\n at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors)\r\n at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback)\r\n at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)\r\n at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)\r\n at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)\r\n at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)\r\n at System.Activities.WorkflowApplication.EnsureInitialized()\r\n at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)\r\n at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)\r\n at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)\r\n at UiPath.Executor.RobotRunner.<>c__DisplayClass52_0.b__0()"
Start Time : 2017/11/02 13:00:05


#2

Hi,
Read somewhere…:thinking:
Make sure to install http package or all the package the machine where robot running.