HTTP activity did not work in the existing bot, but the same activity worked in the new bot

Hi All

I built the API process with HTTP request activity in the existing bot, and I received an empty API response (no errors). I built the API process in the Uipath 2020.10.10 studio version (initially, I built them in 2019.10.4).
I copied the API process steps and pasted them into a new bot. I received the API response with the details in the Uipath studio versions 2020.10.10 and 2019.10.4.

I could not find the cause of the issue as the API worked perfectly in the new bot.

So, I created a new bot and copy-pasted all the XAML files, which I built in the existing bot to the new bot. The API worked fine, and I received the API response.

This is not the issue anymore. But I am curious to know what may be the cause of the issue. Please share your views.


1 Like

Hey @G3Devi

You mean in v2019.x you were not getting any API response but not the case with v2020.x?


Hi @Nithinkrishna

I said the API process in the existing Uipath bot did not work (empty response received). But If I run the API process separately in a new bot is working fine in both the Uipath 2020.10.10 and 2019.10.4 versions.


i had the same problem with the continue activity in a for each. in a new bot it run perfectly in the old one it gives failure. i think thats a bug that happen sometimes.