HTT request

Hi Team,

i get this below error when i preview the HTTP request using credentials.

Could not load type ‘RestSharp.HttpBasicAuthenticator’ from assembly ‘RestSharp, Version=, Culture=neutral, PublicKeyToken=null’.

Hi @Binu

Please provide more context, such as the request in question that causes the error.

I assume you have already tried to install the newest version of the Web activity package?
It is possible that if it is corrupted, you might be lucky to get it running by removing it from this folder:
and then restarting Studio and your project.

Hi ,

it didnt work …

can you help me to resolve this below error . i get this when i try to invoke powershell activity

Throw : A command that prompts the user failed because the host program or the command type does not support user interaction. Try a host program that supports user interaction, such as the Windows PowerShell Console or Windows PowerShell ISE, and remove prompt-related commands from command types that do not support user interaction, such as Windows PowerShell workflows.

i dont find any packages in under userprofile.nuget

Hi @Binu

This is very strange. You should have at least some basic, default packages, like below:


Could you post a similar screenshot, together with the version of the software your are using (Community Edition or Enterprise Edition)?

Lastly, a software reinstall should reinstate the packages to the proper folders and solve the issue.

yes, i see many files, which one i should remove from packages ?

I would suggest renaming the packages folder to something like packagesBackup and restarting your project.
This will force Studio to re-download all packages and hopefully fix the initial error :slight_smile:

I am not sure if it will fix the power shell error though, but we will see.

1 Like

nope ,i got an error when i try to reload… what shall i do to resolve invoke powershell error

i am able to run the invoke powershell when simple script is given in commandtext…whereas i face this error when i pass the arguments and PS1 file.

Okay, I guess we will need more information.

First of all, is the error from the first post fixed now?
Then, which version of Studio are you using? Is it a Community Edition or the Enterprise edition?

Could you maybe share the zipped workflow with simplified script that is causing the error for you? It would help to be able to see it :slight_smile:

First error still prevails. i am using enterprise edition.

second one -powershell error , script with invoke webrequest/restmethod in it. how do i run it …run powershell activity or Invoke powershell…can you share some examples


The powershell command executed by removing the write -host command .Thanks for the reply :slight_smile:

1 Like

I’m glad it helped. It would be awesome if you could post an explanation of the fix on a dummy sample powershell script with any sensitive info removed for other users who would have the same issue in the future.

Also, if you happen to have the Enterprise license, you can always contact our support for any type of issue that was not yet solved on the forum :slight_smile:


my script had user interaction commadn called " write- host" . so when it was removed , it worked.

Can you please let me know how to pass the values to powershell script with examples ?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Sure, see this post:

Here is the slightly updated version that includes both in and out arguments: (2.5 KB)