How to work with Jenkins

Hello Folks,

Could any one let me provide the guide or suggest how to integrate Jenkins with Uipath and make continuous CI/CD. Downloaded the jenkins plugin from Uipath GO. Could any one suggest how to move forward from this

Hi @ushu

Have you tried the documentation available on Go! in the Resources tab?

Thanks for your response. I followed it while trying to build the project I was getting java.lang.illegal exception. I have attached the configuration snapshots and exception snapshots. Could you please check and let me know on the same Please



This plugin version 1.0.0 or before is using java lib which is reading the output to the next end of command string. PowerShell also prints a line separator after it. The method may also return an empty Optional if the stream ended before the end of command was reached, but that should not happen under normal circumstances.
Can you please try with the newer version of the plugin 1.0.1-beta, it shouldn’t face that issue,as it is not dependent on that lib?

Thanks for the response. Could you plz let me know Where we get the 1.0.1- plugin, we previously downloaded plugin from Uipath Go. Please suggest on the same. I also would like to know is there any issue comes if the robot is not present in c:\Program files(86)\Uipath Studio\robot.exe because in my system the robot is present in C:\Users\miracle\AppData\Local\UiPath\app-19.4.2\robot.exe. Please suggest

I guess, it is available now in Go itself https://go.uipath.com/versions/jenkins-plugin-for-uipath-public-preview. You can download it. And yes, robot is to be expected in specified location in Program Files.

Thanks for your prompt response. Will check on it and will get back to you if I face any further issues

Team,

As you were told the robot path should be in “C:\Program Files (x86)\UiPath Studio\UiRobot.exe” so I uninstall and installed it again but the robot is in “C:\Users\miracle\AppData\Local\UiPath\app-19.5.0-beta0024\robot.exe” different path. I don’t know why it was not saving in the default path. Could you please suggest on the same

Hi @ushu

Don’t worry about that part, the Program Files location is for the Enterprise Edition and the AppData is for the Community Edition. This should normally not affect anything.

1 Like

Thanks for your prompt response. Will try on it

Team,

As per your suggestion I tried with .hpi.1.0.1 plugin uploaded in jenkins. I am getting the new exception. Could you please check and let me know on the same.

Do I need to set path for powershell. Please suggest

Team,
I resolved the issue. Now when i tried to build using Jenkins. It was showing Finished:Success. . But it didn’t create any nuget package within that folder. Plz suggest what should I do now. Its a lot needed

Can somebody help me on this

Hi @ushu,
Have you found any resolution?

If the plugin is not working, have you tried interacting with Jenkins via the UI or API?

Jenkins API Documentation: https://wiki.jenkins.io/display/JENKINS/Remote+access+API

Can you share how you were able to solve the powershell.exe not found error? I am also struggling with that same error

Hi csteffe1, did you make sure that powershell is installed on the agent you are running the pack/deploy command?

HI i am also facing same issue is it resolved
while running it is saying it is not able to fine robot.exe in programfiles path

Try Enterprise Edition instead of community Edition