How to use postgresql database in database connectivity in UiPath?


We use postgresql as a database in our project hence I want to do the database connection with postgresql using UiPath? But I am not able to find how to do that. Can anyone help me in resolving this issue?


Any one has any updates on this?


Hi , I used the ODBC driver provided by postgreSQL. note that you must use the 32 bit driver x86 - UIpath does not seem to work with the 64 bit driver.
for me , it connects OK… however I am having issues committing data to the database.
can any experienced developer help out in configuring this driver properly ? i have tried different options with no avail. I get an error in data insert
“message”: “PSQLODBC35W.DLL : ERROR [42601] ERROR: syntax error at or near “-”;\nError while executing the query”,
“level”: “Error”,
Anyone has any idea on this ? How can I find the actual query being sent to the database ?
any help appreciated !!

for those still having issues with the Insert Activity.
I posted in another thread the solution after debugging my issues.
make sure that Postgres database

  1. database or table names does not contain any special characters. For example, postgreSQL allows hyphens in the database or table names. But errors will be generated if the name of the database or table contain hyphen.
  2. column names must match the datatable
  3. add a primary key to your database table.
  4. column names must be in lower case!! somehow, postgreSQL adds a delimiter for any column names containing capital letters , or column names which could be reserved. For example FirstName column name will require a delimter in the database query to become “FirstName”. I changed all column names to lower case to avoid that. Also if the column name can be confused with a reserved keyword, such as a column name called “name”. postgreSQL will need to delimit this column name too. To avoid all of those issues, make sure table names are lower case, and are not any of the reserved keywords.

if you follow those, things should work just fine. It worked for me . hope it helps.
please post your experience


Very late reply. But you can get it from here.