How to use NEPTUNE

terminal

#1

Hi,

I am recently moved to Main frame automation. @ my client location they are using “NEPTUNE” emulator for there main frame application. If I am trying to launch the saved session. UIPath is able to launch the session but after launching session I am getting the error like “UIPath.terminal.host has stopped working.”

can any one help me how to use this session. I am using the below activities.

Terminal session --> “Attachmate Extra”–> using existing profile.

if I am saving the session from emulator it is saving with .edp.


How to download packages for Mainframe terminals? No option can be found in the Studio
#2

Try @aksh1yadav @andrzej.kniola as they may have some experience here.


#3

Unfortunately I can’t help with terminals - different part of the team handles that.


#4

Hey @venkat

I have worked till so far with Different - Different IBM Mainframes but all look similar depend on provider.

Neptune provider supports exists with terminal i am not aware. Have to check if i have such emulator on my system.

But also wanna know once you will also get access to that emulator.
recently uipath has updated terminal package as well so not aware they have added more provider support or not.

Will find above emulator and will let u know.

For your reference this will be helpful to get familiar with Mainframe automation:

Regards…!!
Aksh


#5

Hi,

I got solution, if I use UIPath internal then its working without any issues.

thanks to all :slight_smile:


#6

Great to know that Uipath Internal is working fine with this Provider atleast :slight_smile:

Thanks for the info and updates @venkat


#7

hi

can you please explain how you resolved this issue i’m using “attachmate myextra” emulator. i’m also getting same error

thank you


#8

@aksh1yadav i am facing same issue here with attachmate extra… i tried internal emulator but it didn’t work work for me… it is able to connect to mainframe with internal emulator but dies within 2-3 seconds.

is there a way out of this?