How to type with accent marks


#1

Hello,

I’m running a process that reads data from a spanish website and types the information to an Excel, Word or txt file. The problem comes when there are diacritical marks, i.e. á,é,í,ó,ü. A workflow exception pops up:

Main has thrown an exception
Message: Write text failed.
Source: Type into
Exception Type: ElementOperationException

I’ve tried to use the Replace function and it works fine, but I was wondering if there is another way to solve this problem.

Thanks!


#2
  • when writing in an Excel/Word it is best to use the dedicated activities (eg: Write Cell instead of Type Into.

  • I’ve made a quick test and can’t find any issue - see the attached; you should upload your workflow or give some repro steps. As a side note you can try different Input Methods.

SpecialChars.xaml (7.1 KB)


#3

SpecialChars.xaml (10.2 KB)
Expanded repro.
Tested with PL/PLP keyboard settings:

WindowMessages (second line) seems to ignore right-alt characters. Interesting bit is that it got all characters that I actually can type normally incorrectly, while those that I can’t are correct.

But if I change the workflow to AttachWindow and change the keyboard settings just for the Notepad to EN/US:

Simulate and Hardware are still correct, but the WindowMessages is reversed (almost - ó is still o).

Still wasn’t able to make it throw an exception though.

Possible workarounds:

  1. Use different Input Method, as @badita suggested
  2. Sync user and application language/keyboard settings to the needed language

Either way there seems to be some inconsistency in WM method - it’s like it’s using a not-100%-accurate mapping.


#4

Not sure if it helps. My keyboard is En-Us. It works.


#5

I’ve tried the same sequence and it Works!
I’m not sure what was the problem because I haven’t changed anything, but thank you for your help Badita and Andrzej!


#6

If any of the answers solved your problem, please mark it as Solved using this button below it.