How to type into an unknown element


I’m currently working on a project where I have to type into a dropdown textbox however the problem occurs when I am able to select the textbox to type into but it keeps telling me that there is no element to be found when running it.

I tried using UI explorer to see if I could edit the textbox in the dropdown but it too tells me that there is no element. I tried using simulateType but it not working either.

Please help.


Hi @Captainshame,

You can use ‘select item’ activity if you’re working on web application instead of simple typeInto.

Still you face the same problem, please attach some screenshots of UiExplorer, maybe then someone could help you out.


So sorry but I am unable to attach the screenshots.

I also tried the ‘select item’ activity and it told me “This control does not support select item”


Use click instead of using typeInto if possible.

But how would I be able to type?

@Captainshame The UI Explorer can not find the element because may be the dropdown textbox is not visible on the screen at that time.

You can try clicking the dropdown option at first, then use type into to type. For capturing the dropdown textbox, use F2 to pause the capture for a bit and meanwhile you could click the dropdown button. When the capturing will resume, capture the element and give it a try.


Hi @AKM_Robinuzzaman,

Yup, I tried that on the dropdown textbox and it gave me the following element which is <dummy/> however when I use the UI Explorer, it gave me the result of “Index was out of range. Must be non-negative and less than the size of the collection”.

I am not exactly sure what is wrong

@Captainshame In that case, it would be very difficult to answer without screenshots of the issue.

maybe you can use the click and send hotkey, down or tab activity


so, you have several options.

Click activity, if this does not work, as you said. you can use Click image, not the best solution but it will work, if resolution is the same in all environments.

Also you have UiNext.Activities, whre you can indicate 3 anchors and then click on, or position you are looking for, also next activities are looking for fuzzy selector and image.

Then you have Computer Vision if it is allowed to use in your company.

Or the basic one, click on element before and then send hotkey tab.


Using click image and send hotkey is not recommended because

Image - if it is different resolution, or something pops up in front, robot will not see it
Click image - If something pops up in front robot will not see it.

If you need more help, let me know


Hi @Radomir_Ivankovic,

The bot is able to click on the textbox but the problem is the bot is not able to key in the data that is being provided.

FYI, the data is coming from excel


aham, so you do have drop down many.

OK, when you use uipath explorer and click on any value in that drop down, what do you get?
can you share? maybe you can use dynamic selectors… if not I have another idea, but lts try this first.

btw, dont type, use “Set Text” it should work, let me know of the outcome


Hi @Radomir_Ivankovic,

Sorry for the late update, but “Set Text” isnt working neither

Also when I use the uipath explorer on the dropdown textbox, it gave me this error “Index was out of range. Must be non-negative and less than the size of the collection”



Have you tried any of other possibilities I suggested?

Next activities, Computer Vision etc…