How to Troubleshoot

Hi - I have tried recreating this process a few times and it is not working properly. Below is the screen from the “Build Your First Process in Studio”.

Is there a way to troubleshoot and see where I am incorrect in how I built the process?


Do step into…from debug panel…and after each step you can check the locals panel and see the variables data and check if values are being populated as expected or not and proceed accordingly



For now, can you share what error do you have?


@Anil_G @Yoichi

Not getting any official errors.

I’m guessing this should not be null?

Also I followed the properties instructions exactly but not sure if anything should be changed here?


If there is no unread message in your mailbox, can you try to uncheck OnlyUnreadMessage property in GetOutlookMailMessages activity?



I guess your filter is removing all emails or the emails are read already


the “course invoices” emails were unread at the time. I went back to double check, and made those emails unread again and it is still showing same results.


Could you clear the subject filter and see if you are getting emails, that would mean your filter condition is not working properly.

If thats the case, what are you trying to filter ?

Ah I realized the problem. I’m using my work email account, and it is assigning an “[EXTERNAL]” to some emails coming from outside the company so I didn’t filter properly.

Thanks all.

I am curious though. Is there a way to filter with finding the words “Course Invoices” as opposed to an exact match?


Can you try a wild card before subject, like a star(*)


Use contains with subject to filter.

How would I write that out - like this? Tried different variations and it didn’t work.

“(*) [Subject] = ‘Course Invoices’”

How would I write that out?

Try this-

@SQL=urn:schemas:httpmail:subject LIKE '%Course Invoices%’

Getting an error.

Is there a shorter way to write it out, or it has to be with the @SQL?

Unfortunately it doesnt support use of wilcard here since its a strict filter, use DASL query instead.


Please put double quotes around the expression @SQL=urn:schemas:httpmail:subject LIKE '%Course Invoices%’, it a string.


Thanks Prateek. That worked.

Is there any good places to go to understand/break down the SQL expression? I am new to UiPath and to programming languages.

Hi - Not relating to the original post, but when I continue on with this automation, I noticed that there are no files in the invoices folder but they are there when I open up windows explorer. I have clicked on refresh. How come they would not show up?


Can you close and reopen your project once,