How to Solve The Recent Validation Error In Excel Application Scope

Hello Guys,

Problem Statement

With the latest update of the UiPath studio, there are concerns around the Excel Application Scope as it throws out validation errors. Many are complaining about this error “Excel Workbook Application is not defined”, and I have personally come across this in my automation solutions.

You could easily locate this error by simply clicking on the Validate button on the top ribbon. If you have excel application scope, most probably you’ll see this error. It doesn’t show up unless you do this validation. And even though this error persists, you will not see a validation icon on the top of the Excel Application Scope.

As you see here, the Excel Application Scope is pretty fine.


So this error is caused by this property of the Excel Application Scope

The way to resolve this is by creating a WorkBook Application type variable and assigning it to this output argument. You can simply click there, and press CTRL + K and then type the variable name. This will create the workbook application type variable and assign it to the output argument of this activity.

Once done, click on the Validate All and see the error gone :slight_smile:

For all the projects that run on latest versions, having this will be really required. In might work fine, but this validation error will stop you from validating the solution and even from publishing to the orchestrator. So if you have the Excel Application Scope used, make sure to apply this change and it will be fine after that :slight_smile:

Thank you and Happy Automating!!!


THANK YOU!!! And my BOTS thank you too.

1 Like

This does resolve the error

1 Like

Thanks for the guide @Lahiru.Fernando, we’ll have a look what is wrong there :slight_smile:


hi ,

doesn’t work, getting same error

HI @smita.mobifly

DId you add it the variable to the output argument of the excel application scope?

And also, once the change is done, click on the Validate all button again to perform the validation. It should work… follow the steps slowly and step by step… :slight_smile:


yes added, didnt understand what is the issue


I think you are having more than one excel application scope activities… Since your are working on the RE Framework, this can be possible as re framework also includes some excel application scope activities in workflows we normally don’t get into…

Easy way to find it out is:
Open the errors panel, Double Click on the validation error. It will navigate to the activity which is throwing the error. So I assure that you will find the next application scope there :smiley:


:point_up: Update The issue is fixed in the latest beta 2019.9.0-beta.101 :slight_smile:

:point_down:After some more tests, it seems that the issue also manifests itself within the Computer Vision scope as well as Exchange Scope.

If you are getting these errors when publishing a project with:

  • Exchange scope
    Type 'Microsoft.Exchange.WebServices.Data.ExchangeService' is not defined"
  • Computer Vision scope
    Type 'UiPath.CV.CvDescriptor' is not defined

Please use these workarounds:

  • for Exchange Scope

    • Import the namespace Microsoft.Exchange.WebServices.Data
  • for the CV Scope error

    • Uninstall the UiPath.ComputerVision.Activities dependency completely, then reinstall it again;
    • Make sure that you have installed a compatible UiPath.UIAutomation.Activities package (you can upgrade this package first, then reinstall the CV package). A known working combination is UiPath.UiAutomation.Activities 19.8.0-ce and UiPath.ComputerVision.Activities 2.1.0

thanks mate, just started with UIPath and got this error, your post helped to resolve it!

1 Like


I have tried this solution, and I am still having the same problem. I have tried creating a simple variable and using it for every Excel scope, also tried to use diferent variables each for every excel scope… nothing.
I have tried downgrading the excel activities package… Also upgrading… Nothing
I also the same type of error with databaseConnection…

Please! There is someone who can help me resolving this issue?
Thank you so much!

Thanks, this fixed errors with CV!

1 Like

Thank you , this helped me a lot :smiley: :smiley:

:point_up: Update The issue is fixed in the latest beta 2019.9.0-beta.101

1 Like

Thanks :slight_smile: … Will check

Thank you! Just start ReFramework, it’s useful of your post! :slight_smile:

I still receive the same Computer Vision scope errors with the latest stable Studio.

Hi @bogdanxd

Could you make sure you have all the latest packages installed in your project?


I updated with the last package (UiPath.UiAutomation.Activites 19.10.0 - alpha) and now everything is up and running, no more errors and I can publish the project.
And for far as I can see, the computer vision activites is now included in the UiAutomation activites package.

Thanks @loginerror

Good Lahiru.Fernando its work for me.

1 Like