How to set the bot login PC domain from locked screen before start the process


#1

Problem: Process was thrown an exception error because of Time out at Send Hotkey activities processing. (My bot running in background)

Condition:

  1. In our company security control policy every PC/Laptop must be logoff to lock screen when Idle for 15 minute.
  2. Bot process including activities which won’t work in Background such as “Send Hotkey”, “Type into Security”, etc,…
  3. Bot type is “Unattended”

Question: I would like to know how to set the bot run in foreground, meaning is Bot must login PC domain before start the process.

My Steps:

  1. Connect Bot machine with Orchestrator, setting with Domain/Username and password
  2. My process has been set with scheduling. On every Thursday 05:30 AM.
  3. The Bot machine was turn on and locked off the screen when leave to Idle over 15 minute.
  4. When reach the schedule at 05:30 AM, the bot can start process as normal in background mode (not login domain). The bot run until “Send Hotkey” process. And then stop because of timeout (thrown exception error).

#2

Once you connect bot to orchestrator, each time when bot i running it will automatically login to machine and start the run.


#3

May be somethings have to set as a configuration of Process Trigger. In previous I tested with another process, it was automatically login. But I try that process again and won’t work right now.


#4

Try scheduling it with “Task Scheduler” by checking checkbox for “Run whether user is logged on or not”. Also keep ‘SendWindowMessages’ checkbox checked in properties panel for ‘TypeInto’ and ‘SendHotKeys’ activities.


#5

Appreciated for your advice.

In my company Bot scheduling run will be control via Orchestrator under IT department managing and control. Any idea to stand for Orchestrator scheduling and trigger run with Auto login sir?


#6

Can you give more details about this? I don’t understand. So previously the robot will login and then start the process - how long between logging in and starting? And what is the current behavior? Did something change: Studio/Robot version, package version, Orchestrator version?


#7

Now I found the root cause. The bot will not auto login in case of the machine was setting the screen saver option is “3D Text or Blank or Bubbles or Mystify or Photos or Ribbons”. Only one option worked is “None”. You can test with auto locking off by checked “On resume, display logon screen” and select screen saver option as I mention. Then command to process the bot via Orchestrator, surely that the bot will run on background without auto login the domain. It won’t work if you have some activities which not capable to run on background including the process.


closed #8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.